Launcher broken again, second time!

Hey there, my Son and me can't start the Game since today. We already had such a problem 2 months ago after an update. I have attached two Screenshots for this.

first.png second.png

We tried the same Solution as then, which is also pinned in the Forum. However, the Launcher now starts in Japanese and spams many Errors in Japanese ... 😞

Now we are slowly perplexed and frustrated. We always lose so much of our Premium Pass Time because of this. Why do there have to be such annoying things every time. Even reinstalling the game doesn't help.

And this Problem is not only for me and my Sons Computer, there are some affected. And yes, everything is up-to-date!

Asking for help, thanks!

Same problem here. Playing on Steam - Windows 10 - France

Open to all suggestions 🙂

https://www.reddit.com/r/PSO2/comments/ke6y6l/the_whole_steam_game_deleted_itslef_once_again/

Apparently it's because the steam port updates to the wrong version.

Auto mod is deleting any further topics on the issue.

Tweaker seems fine, if you can get it to work.

Same problem

This post is deleted!

I had the same thing. That's becouse update on steam is changing permissions of some filles in PSO2 folder. You must change them back to you again but you must do this in a special way.

  1. Launch the game normally (pso2launcher.exe in game folder), DO NOT CLICK on Back and keep it as it is
  2. Go to the game directory, right click on pso2_bin > Security > Advanced > Replace all authorization entries
  3. Once done, click on Back, should have no error and the update window
  4. Once closed, repeat Step 2 without launching the game
  5. Launch the game through Steam

On STeam, I had the launcher update to episode 5 launcher after maint. But instead of clicking start game at all, I closed the launcher and re-opened it. It updated a second time, and worked fine after.

@Racer-0 said in Launcher broken again, second time!:

I had the same thing. That's becouse update on steam is changing permissions of some filles in PSO2 folder. You must change them back to you again but you must do this in a special way.

  1. Launch the game normally (pso2launcher.exe in game folder), DO NOT CLICK on Back and keep it as it is
  2. Go to the game directory, right click on pso2_bin > Security > Advanced > Replace all authorization entries
  3. Once done, click on Back, should have no error and the update window
  4. Once closed, repeat Step 2 without launching the game
  5. Launch the game through Steam

Yeh... did that but after that everything went to Japanese and now Launcher spams Errors in Japanese Language! Thats what i wrote above, this time the old "Trick" don't works correctly, same for my Son & Friends, we all have broken Clients and to delete + reinstall it also don't helps!

@coldreactive to restart the Launcher also don't helps much, Error shows up each time!

It's pretty sick that we have to deal with such crap after each Update! And that for such an expansive and Money Farming Game!

@MrBlingbling said in Launcher broken again, second time!:

@coldreactive to restart the Launcher also don't helps much, Error shows up each time!

Probably because you clicked start game the moment it finished updating the first time, which I didn't do.

@coldreactive @MrBlingbling Nope, I ahve the same thing like him with "japanease" but I didn't click it after 1st time. I done that normally. After it if you want to play again you must do the same trick like before for it to work. But you must do it over and over again after you close the game 😕

@coldreactive said in Launcher broken again, second time!:

@MrBlingbling said in Launcher broken again, second time!:

@coldreactive to restart the Launcher also don't helps much, Error shows up each time!

Probably because you clicked start game the moment it finished updating the first time, which I didn't do.

as you can see inside my Screenshots there is no "START GAME", this Screen Views directly show up after starting the Launcher. As well after doing the Trick it just start and showing Errors at Japanese, no Launcher, no start Game... nothing!

@Racer-0 said in Launcher broken again, second time!:

I had the same thing. That's becouse update on steam is changing permissions of some filles in PSO2 folder. You must change them back to you again but you must do this in a special way.

  1. Launch the game normally (pso2launcher.exe in game folder), DO NOT CLICK on Back and keep it as it is
  2. Go to the game directory, right click on pso2_bin > Security > Advanced > Replace all authorization entries
  3. Once done, click on Back, should have no error and the update window
  4. Once closed, repeat Step 2 without launching the game
  5. Launch the game through Steam

now it's worse, now not only throw errors but in Japanese:D

@Chantro It's an old trick and if you do it in a correct way you are able to play but some things in launcher only after it are changed to Japanese, but you are still able to play it by pressing big red button in launcher. And a 2nd minus of this trick now is that you must do it over and over again every time when you close the game (when you don't do it and try to launch game in normal way you will see many japanese errors). It's sick shit that there is always some problem after update in most cases. BTW this trick before was working normaly, it didn't changed the language and everything worked after doing it 1 time, soo I think they changed something in this update that make things more bad than before.

Some people can't actualy read the topic... Insane