Error 667

Receiving an Error 667 when trying to log into a Ship. New Open Beta player

From what I understand, it means the ship is too full.

yikes, that's unfortunate

Still looking for help with this, if anyone might have some suggestions. Support has been slow to respond so far. I encounter the error when attempting to log into any of the Ships, or Getting Started option. NAT looks good on XBOX and I've added a port forward in the range of 12000-12999 based on what I've seen in their FAQ.

@DeadDawg this might seem like a silly question, but does your XBOX Live account have gold time?

I haven't seen anything about this error yet, so thought I would try asking an Xbox specific question.

it does 🙂

@DeadDawg yeah I just tested it on an account without gold, it just forced the Gold window to pop up.

The staff community staff should start showing up soon, so hopefully they can help you out!

@John-Paul-RAGE thank you for the response, hope to hear from them soon. Anxious to get in!

Im having this error too, I had my Window updated and even tried re-installing but the same problem It sucks seeing the server getting full and crowded while Im getting this error and not being able to start at all.

Necro time. I was able to log in earlier, now I'm getting 667ed. I waited ~2 hours, still no joy. I can't access Support, when I try it says "No XBox Account found" but Microsoft just let me change my password. I have Game Pass Ultimate and play on XBox. I can still use my GP games.

Xbox live is off

Thanks, I found out when I restarted my Xbox and couldn't log in to the Xbox itself. It is back but now I can't even get off the title screen.

@Kodiakmax-101 Its not back at 100% and judging by the Twitter support feed, Xbox live is still technically down, even if you can sign in. I'd just go read a book, or watch YouTube if that's back up at all.

Edit: rebooting fixed the problem.

Wow, got this error message too. (Using Epics store).

Feels really bad because I told my team to wait for me...

@Cakewalk A lot of companies were having server issues at around the same time. Quite odd.