Serious Server-Sided Lag the past week or so in bursts

I and several others have been experiencing issues where the server hasn't been communicating properly with clients. How do I know it's the server's fault?

  1. Websites all work fine during the lag. (Twitter, YouTube, Steam, and even this forum.)
  2. Enemies will sometimes lag, but not certain users. (IE: During trick or treat, all enemies stopped, but I could see some users still changing direction on their gun turret during the lag.)
  3. Chat still worked for some users. (In most MMOs, chat is actually done on a parallel server so that players can communicate even when the main game's server is lagging.)

Today I had a large burst happen during a menu, and the game wouldn't let me out of the menu.

alt text

you don't need to check if the rest of the network is working when is happening to others ingame, server related issues will always affect several users at the same time and even the Azure Servers that are pretty strong servers are not immune to those issues

@coldreactive I have the same issues from time to time and, aside from the random disconnection problem that went away since last patch (I'm not on wifi and everything else was working fine), some annoying desynch were mobs teleport themselves elsewhere.

I also have issues with "Plotting the Ultimate Defense" randomly crashing on hardcore version only (I have completed it after trying many times, with crashes happening after 30 seconds or after some minutes).

had it happen yesterday in middle of a urgent quest when went to run it again. was stuck in the infinite loading

@ShadowBlood89 that you got there is a desync and those normally happen when you suffer a small lag during the connection with the server that doesn't cause a DC

Just to answer a few of these...

  1. Websites all work fine during the lag. (Twitter, YouTube, Steam, and even this forum.)

The websites is hosted on a completely set of servers separate from the game.

  1. Chat still worked for some users. (In most MMOs, chat is actually done on a parallel server so that players can communicate even when the main game's server is lagging.)

This is correct, I dunno how things are now that the Steam version is live... but back then PSO2 used the Xbox Live servers for all forms of communication. Whenever Xbox Live was having an outtage chat related functions like emotes and chat messages would not work.

I noticed something like that in Buster and Trick or Treat. Players were moving fine but the monsters were stuck in place for a couple seconds. It was nothing major, just noticeable.

@Milk that happens when the latency is pretty high in the connection or when the server is not being able to handle however I doubt this is the case with the Azure Servers so probably was a problem with the server that handles all the connections to the main server