In weapon palette window, in the rightmost top corner of every weapon palette, there is a box. In a box there is a tick, and if you uncheck it, palette will no longer be shown in "Cycle weapon palette" menu unless you put the tick back. At least that is how it supposed to be, except ti doesn't work. For several mounths.