Game stuck ad loading screen after launch

Hello! The game is stuck at this screen and won't launch. How can I fix the issue? I use Steam. Thank you in advance. 20200806_220747.jpg

I know it's not helpful to be the "one guy", but I am currently trying my hardest to fix this exact same issue on my brothers PC.

Weirdly enough you are the only other person I have found with this exact issue.

On mine I have no issues at all. I downloaded the game from steam and it just worked flawlessly. However my brother has had this issue ever since he tried to start the game for the first time. We tried everything the tweaker could offer, reinstalling, checking files, checking permissions etc....I even gave him my copy of the game from my pc over to his..nothing worked.

From that I gathered that it has to be some sort of issue with his PC specifically. However he is on the newest version of Windows 10, has is graphics card drivers updated and everything.

We moved it between harddrives to see if maybe that was causing issues, no luck. We disabled literaly everything except the game (so only it was running). No antivirus, no windows defender, no firewall, no program, nothing. Reinstalling and checking the game through steam itself also did nothing. I am at my actual end here. It is insanely frustrating.

We just wanna play together.

So if anyone has any idea or maybe you have found a fix for this, I would be insanely grateful.

Since in the image it shows that the game isn't responding, the first thing to check is the Event Viewer in Windows. Check the Application and System Logs to see if there were any errors or warnings or anything and see what all was involved with them. This can normally help narrow down the culprit for why a program doesn't work.

@Ragnawind said in Game stuck ad loading screen after launch:

Since in the image it shows that the game isn't responding, the first thing to check is the Event Viewer in Windows. Check the Application and System Logs to see if there were any errors or warnings or anything and see what all was involved with them. This can normally help narrow down the culprit for why a program doesn't work.

So he did that and it just gives out this:

  • <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  • <System> <Provider Name="Application Hang" /> <EventID Qualifiers="0">1002</EventID> <Level>2</Level> <Task>101</Task> <Keywords>0x80000000000000</Keywords> <TimeCreated SystemTime="2020-08-07T21:25:37.985036300Z" /> <EventRecordID>44521</EventRecordID> <Channel>Application</Channel> <Computer>"x"</Computer> <Security /> </System>
  • <EventData> <Data>pso2.exe</Data> <Data>0.0.0.0</Data> <Data>31d0</Data> <Data>01d66d011f98cad0</Data> <Data>70</Data> <Data>C:\Program Files (x86)\Steam\steamapps\common\PHANTASYSTARONLINE2_NA_STEAM\pso2_bin\pso2.exe</Data> <Data>bc7ce398-a7a3-48f9-a355-6ea9e06ee04e</Data> <Data /> <Data /> <Data>Unknown</Data> <Binary>55006E006B006E006F0077006E0000000000</Binary> </EventData> </Event>

and I can't really make any sense of it. It gives out information that it can't describe the error. I would post it, but it's all in german. X:

@Ace-0 : It seems like a typical hang with that, but without a faulting component like normal. Do you have the specs for a computer that it works on and what is doesn't work on? It should include: OS (version and build if applicable, as well as the bit version 32 or 64): CPU (name and speed): RAM (amount and type): GPU (brand, model, manufacturer, amount of RAM,etc):

EDIT: Also, you might want to remove personally identifying info, such as the PC name from your post above.

@acco-gamesx : It would probably help if you could provide the specs also, if possible.

@Ragnawind So these are my brothers current specs, so the system that it doesn't work on:

OS Name Microsoft Windows 10 Pro
Version 10.0.18362 Build 18362
Processor Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz, 3501 Mhz, 4 Core(s), 4 Logical Processor(s)
BaseBoard Manufacturer Gigabyte Technology Co., Ltd.
BaseBoard Product Z170-HD3P-CF
Installed Physical Memory (RAM) 16.0 GB DDR3 Total Physical Memory 16.0 GB
Graphics Card NVIDIA GeForce GTX 1060 6GB

and mine that it does work on:

OS Name Microsoft Windows 10 Pro
Version 10.0.18362 Build 18362
Processor Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz, 4 Core(s)
BaseBoard Manufacturer ASUSTeK COMPUTER INC.
BaseBoard Product PRIME B250M-PLUS
Installed Physical Memory (RAM) 8.0 GB DDR3 Total Physical Memory 7.95.0 GB
Graphics Card NVIDIA GeForce GTX 1060 6GB

Doesn't seem like anything should be causing an issue hardware-wise, unless maybe the RAM is bad. A memory Test should rule that out. If the RAM checks out, there must be some kind of program or driver preventing it from running, but you seemed to have ruled that out already. You might have to submit a bug report to SEGA included the detailed information about the App Hang. It could take a couple of weeks to hear, back from them, though, since they are often slow in responding it seems. You can contact them here: https://support.pso2.com

Gonna queue up a memory Test to be sure. Already submitted support ticket about the whole thing. Maybe they know something else. Thank you though for taking time out of your day to try and help us!