Getting tired of Error 630

Look, you guys really need to sort this crap out. I have been kicked by the error 3 times in the last 30 minutes and what do you know that you did an update today. How is it every time you update the game I am kicked by this nonsense error. This especially ticks me off because I am TRYING to enjoy Episode 4 that just released but thanks to this piss poor error I am unable to do so.

@CannonFodder886 havent been hit yet today but happens very frequently. It also seems to be tied to UQ's starting, almost everytime that message pops up I worry good ole error 630 is coming for me. I did a delete and reinstall and it seemed to slow the frequency of error till last night anyhow. No response from my support ticket.

I can't even get through the tutorial because of this error

This is all i have received from support,looks like a bot reply to me.

Hello ARKS Operative,

Thank you for the detailed response. We will forward this information to the proper team for further investigation.

We are currently investigating the issue and we are looking for a fix at this time.

We apologize for any inconvenience this may have caused. Thank you for your patience and understanding while we are resolving this issue.

  • The PSO2 Team

The inconvenience has been many lost advanced capsules 😞 I understand they are busy with the ep4 and steam release but this started 3 weeks ago I had no prblems until then and have played since beta.

Holy shit, by pure accident I found a workaround. So in order to test weather it was about to kick me I noticed that when you tried to switch weapons it wouldn't switch. So if I stayed on the game screen it would eventually kick me with error 630 every time without fail. By chance on one occasion this happened I alt tabbed and after a bit I alt tabbed back and my connection was fixed. Just in case I kept testing with weapon switch and when that would happen I would alt tab for a few second go back in and test and repeat until it fixed itself. By some miracle I was finally able to get past the tutorial this way without getting the 630 error.

Hmm Im on xbox so maybe i will try to go to dashboard see if it does anything.

It kicks me no matter what I am doing. Whether I a chilling in lobby or I am just questing. Point is they still dunno how to make to make a game that was never their own work.

Just an update, that workaround may have been a fluke. But I finally managed to fix it by replacing some wires on my end (so far at least). Be sure you check all your ethernet and cable wires. Just jiggle them all a bit, consider replacing some if you think they might be faulty. My issue seems to have been a crappy cable.

After maintenance I played 2 nights without a 630 so I thought maybe they fixed it. But lastnight I was attacked by the 630 monster several times 😞

The problem is not your enthernet, wifi or whatever you use the bs is on pso2 na side and it is definitely tied to urgent announcement, deploy and end but i notice recently running to pvp or challenge lobby during the urgent phase and returning back to the ship i didnt get hit by EC630 and i always get it three times during any urgent time.