Can't launch game

It seems as if Windows Store is trying to update the game - I've tried repairing, I have tried deleting and I can't even uninstall the game. I have bought 5 months of premium time and have spent several days already just trying to get the game to work because Sega and Microsoft can't figure out how to keep permissions between updates.

This is the single most frustrating experience I have ever had with a a game and I've been gaming since 1982.

MStore.JPG

Whenever I try to delete PSO2_bin - I get an error - even though I am logged in as admin and running 7zip as admin. The repair has been running for over 30 minutes now...

You have to delete pso2_bin in Program Files\ModifiableWindowsApps and restart the computer.

That's the only fix. If it won't even allow you to do that, you can work around the permissions by doing one of the following:

Start Windows 10 in Safe Mode and delete the folder

  1. Documentation here on how to start in Safe Mode.
  2. Delete the pso2_bin folder in Program Files\ModifiableWindowsApps
  3. Restart in normal mode.

Get a Linux LiveCD and delete the folder

  1. Go get an Ubuntu LiveCD. (Documentation here.)
  2. Tell your PC's BIOS to boot from the CD/DVD/BD-ROM Drive or USB Stick that it's installed/imaged to.
    • If you don't know how to do this. Try shutting down your computer completely, and holding the DELETE key (or "Del") while the system is booting up. The key required to be pressed down varies based on the motherboard. This should bring up the BIOS for your computer. BIOS navigation is usually done using the arrow keys on your keyboard. A More modern BIOS may allow wired mice.
  3. Mount your hard drive in the LiveCD.
    • Right-clicking the detected drive should give an option to mount. It may already be mounted though.
  4. Navigate to the Program Files\ModifiableWindowsApps folder and delete pso2_bin. (Make sure to empty the trash.)
  5. Shut down the computer completely.
  6. Take out the CD/DVD/BD-ROM or USB/Flash Drive.
  7. Start the computer normally (without a key pressed) from the hard drive.
    • If 6-7 doesn't work, repeat step 2 but tell the PC's BIOS to boot from the hard disk. Then start the system normally without a key pressed.

Re-install Windows 10 Completely

  1. Back-up all of your documents that you want to keep onto a flash drive, google drive, etc.
  2. Go to Updates and Security in the Settings.
  3. Go to Recovery, and choose "Reset this PC."
  4. Choose "Remove everything."
  5. Choose the option to DOWNLOAD WINDOWS 10. (This is the easiest option.)


As a rule of thumb: Never, ever install a game to a secondary hard drive. Always install it to the same drive as your Operating System. Period.

I have tried deleting PSO2_bin but it seems like something is open or being used by the system as it won't let me. Yeah, I am not re-installing windows 10 as I have now done that twice - I'm doing charge backs and quitting. This is ridiculous.

@Itesh said in Can't launch game:

I'm doing charge backs and quitting

Just hope Microsoft doesn't ban you from ever using the Microsoft Store again. (This includes the Xbox Store.) Like Square Enix does.

When the steam version comes out, I guarantee you, that you'll have to buy the Cash shop stuff via the Microsoft Store in a steam pop-up like other MMOs do by popping up a dialogue box that takes you to their third-party website store.

At this point, I don't care. I know what I'm getting myself into - I've run Support at several online gaming companies (Cryptic Studios, Linden Lab, Wargaming America) - so I know if I do charge backs, I will be banned in their system for life. At this point - I am willing to completely step away from the MS gaming ecosystem due to the horrible way they have implemented PSO2.

As stated previously, this has already happened to me 3 other times, this is probably the last straw for me. In fact, will be opening up a BBB ticket as well just for good measure.

Ok, was finally able to use 7zip to delete this folder and the stuff in mutable back up. BTW - Sega, please work with Microsoft to fix this. The mutable folder was taking up this much space on my drive - in addition to the 56GB of the install. Just plain ridiculous.

fixyourshitms.JPG

@Itesh said in Can't launch game:

I have tried deleting PSO2_bin but it seems like something is open or being used by the system as it won't let me. Yeah, I am not re-installing windows 10 as I have now done that twice - I'm doing charge backs and quitting. This is ridiculous.

When the folder won't let you delete it, it means you tried to run the game since the last restart of the computer. To delete it from that state, there are two options:

  1. Restart the computer and delete it, or
  2. Open Task Manager and close gaming services from the processes tab.

I'm getting the same problem, but i'm too dumb to understand all those program things. I just wanted to play the game for the first time ;-;

Okay, here is the simplest way I have found to delete everything and start over - just delete PSO2_bin and everything the mutable backup folder using 7zip. https://www.7-zip.org/

@AnimeExplorer

  1. Login with Administrative rights
  2. Download the above and install it
  3. Go to file explorer and left click on it
  4. Go to the upper left and click on File>>Change folder and search options
  5. Click on the View tab and go to hidden files and folders - select Show hidden files, folders, or drives. Click Apply and then OK.
  6. Go to the Windows Icon (lower left-hand corner), click on it, find 7zip and right click, go to more and Run as Administrator.
  7. In 7zip go to C:\Program Files\ModifiableWindowsApps (replace C:\ with wherever you have PSO installed) and delete the PSO2_bin folder.
  8. Go to C:\Program Files\WindowsApps\MutableBackup\ and delete all of the oxyna folders in there (you may find multiple copies).
  9. Restart your computer and go to Windows Icon and launch the Microsoft Store. Search for Phantasy Star and click on the button - the game should start to download once again. After this, you should be able to login once again.

When installing 7-zip, it automatically asks for admin privileges to install. If it doesn't, you can simply right-click the file and run as admin to install it as admin. You don't need admin privileges to delete the modifiablewindowsapps pso2_bin folder as long as a program isn't using the folder. (The restore feature of Windows Apps doesn't usually do that, since I did that too once.)

@coldreactive Thanks, just making sure I was covering all the bases.

@Itesh I will try my best to do all that, I can mostly understand what to do now, but if I go though these steps one at a time, I'll probably be able to get Phantasy Star working again

Tysm for the help 😄

@coldreactive thank you for this. Deleting the folder in safe mode worked for me.

When I started the program after deleting the folder and restarting, the launcher began to update. So maybe something in the bin folder prevents the update? Just taking a guess.