PSO2 Tweaker help, I don't know what happened

So just recently I've encountered a problem with the Tweaker, I have no idea what happened, I literally just played this game this morning and everything was fine. I have no idea what's going on, all I can give is the rundown from the tweaker

Retrieving information from SEGA's North American patch server... Download File Exception - System.Net.WebException - -2146233079: The Operation has timed out Failed to connect to the North American Patch server! Could not find the file 'E:\Games\Arks-Layer\PSO2 Tweaker\management_beta.txt'.

This was happening even after I deleted and uninstalled the game and tweaker all together, I really like this game and I really don't wanna be forced to quit like this, if anyone knows what going on, pls help.

I want to think this is a simple fix, so I'll show you what to do:

In your PSO2 Tweaker folder. create a new .txt file with the name "management_beta" (it should be placed in the same folder with the .exe of pso2 tweaker)

Then open that .txt and copy/paste the following:

IsInMaintenance=0
IsExpired=0
IsLeavePrecede=1
IsThread=0
ThreadNum=1
TimeOut=30000
ParallelFileSize=10485760
ParallelThreadNum=1
CrcThreadNum=1
FileCacheSize=10485760
RetryNum=10
IsPGO=1
CloudThreadControl=1
MemoryOptimize=1
MasterURL=http://download.pso2.jp/patch_prod/v60700_rc_86_masterbase/patches/
PatchURL=http://download.pso2.jp/patch_prod/v60800_rc_87_184A693C/patches/
BackupMasterURL=http://sub-download.pso2.jp/patch_prod/v60700_rc_86_masterbase/patches/
BackupPatchURL=http://sub-download.pso2.jp/patch_prod/v60800_rc_87_184A693C/patches/

Hopefully this works out for you, and lemme know if it does nothing.

It didn't work, but I can now install it after switching internet connections to my mobile hotspot, no idea what's up with that tho,

Edit: So I have no idea how or why, but I use Ethernet, and youtube and google work completely fine, so I tried disconnecting my ethernet, and my PC says "No Connection" when I connected to it, so I tried turning off my router and turning it back on again, got the connection back, and now going through the pain (Cause I now realise I didn't have to delete the fucken game) and pleasure of reinstalling my game.