Getting NP1002 Error

Game uninstalled itself, so I tried re-downloading but wasn't able to launch through MS store. I had a work around by having the psobin folder stored in a separate hard-drive so I can just copy paste the bulk back into the main folder(C). Was working pretty good for about a month. But unfortunately today I enabled some settings on windows defender, don't remember which one exactly, and now no matter what I'm getting the NP1002 error.

I already tried pso2 tweaker and still get that error. I ran a sfc /scannow and my windows is updated. Don't really know what else to do. Any ideas?

@Sideshowphil408 said in Getting NP1002 Error:

Game uninstalled itself, so I tried re-downloading but wasn't able to launch through MS store. I had a work around by having the psobin folder stored in a separate hard-drive so I can just copy paste the bulk back into the main folder(C). Was working pretty good for about a month. But unfortunately today I enabled some settings on windows defender, don't remember which one exactly, and now no matter what I'm getting the NP1002 error.

I already tried pso2 tweaker and still get that error. I ran a sfc /scannow and my windows is updated. Don't really know what else to do. Any ideas?

You are going to have to go back into your Windows Defender and Look for the Quarantined files and then restore them. If you able to do so, make sure that you add PSO2 to your list of "Safe" programs as an exception in Windows Defender.

The NP1002 is just a Game guard Error., That usually happens when it detects a app that it doesn't like. , in this case- Completely Disable windows Defender and give it a Go.

@DDDDLife Thank you for the suggestions. There were no folders/files in quarantined. There is nothing in the protection history even with all the filters enabled/disabled. I already added all the folders that include PSO in the exclusion list. I tried disabling windows defender, firewall, everything. And I'm still getting the error. 😞

@Sideshowphil408 said in Getting NP1002 Error:

@DDDDLife Thank you for the suggestions. There were no folders/files in quarantined. There is nothing in the protection history even with all the filters enabled/disabled. I already added all the folders that include PSO in the exclusion list. I tried disabling windows defender, firewall, everything. And I'm still getting the error. 😞

You could also Delete the Entire Game guard Folder , Then start your PSO2 game. The game guard should be re-downloaded and re-installed and it should allow for your game to start.

@DDDDLife I have also tried that, along with using the PSO Tweaker to repair the gameguard folder. I see that it downloads on the top left, but still same error 😞 I'm at a lost!

Try and Completely Disable all Antivirus programs along with windows defender.

@DDDDLife Yes I attempted that too and still didn't work. I don't have any other anti-virus programs. I guess another choice would be to do a clean windows boot, which I'd really prefer not to.

What version of Windows 10 are you on? Is it the May 2020 Update (Feature Update 2004). Many seem to think that causes a problem. Other problems would include whether or not Windows is a legit activated copy, if there are any hidden viruses on the PC, third party programs that monitor the PC or network traffic, etc. You also can't run the game in a virtual environment.

@Ragnawind Yes, I'm on the 2004 update. I have an authentic activated version of windows. I don't think I have any virus's since it's a brand new pc.. Windows defender hasn't picked up anything either. I'm not sure what you mean by virtual environment like remote desktop? If not, no i'm not. maybe only virtual fullscreen?

Update: it is now resolved. I emailed gameguard and sent them the ERL files and they were able to troubleshoot for me. Apparently, windows was running a debugging. Here are the steps:

  1. Run CMD as admin
  2. Check debug settings after typing 'bcdedit'
  3. Enter 'bcdedit /bugoff'
  4. Enter 'bcdedit' to confirm setting change(should see debugging off)

Restart PC and delete gameguard folder or run PSO tweaker gameguard troubleshoot. And should be good to go. I hope this helps someone. GL!