Regular Crashes on Seabed Exploration (and randomly in Ruins & Floating Facility)

Hello, I've been experiencing a regular and reproducible crash in the Seabed map; I will CTD within few minutes of being in the map, where my screen will blank out in a random color before closing or hanging. Sometimes a dialogue box pops up, saying "Another Application has forced the game to close", which seems to be gamegaurd but I've also tried closing all other background processes to no luck.

I've checked files, permissions and security options numerous times. I tend to find that I'm missing exactly 55 files when I do this, but after re-downloading said files, I still crash if I enter a seabed map. I have also ensured the correct GPU is being used when PSO2 is running.

A similar crash occurs randomly, and fairly rarely on the Ruins and Floating Facility maps. I think it's a bad or missing asset that causes the crash, but I dont know what it could be.

Any ideas on how to fix this? Everything else in game runs just fine.

bumping because seabed is a map in the rally, and this sucks.

Having the same issue as well with 56 missing files, but still get random crashes. Using 980ti and updated graphics driver to latest and noticed the crashes beginning July.

Interesting, I'm also running a NVIDIA 980ti and Seabed is almost always a guaranteed crash for me. On Windows and Steam Versions.

The Halloween map was pretty bad for awhile also, I had to play on my XBOX just to finish the event.