Game performs horribly, FPS drops severely in quests (not Lobby issue)

Hello, I'm having some serious frame lag when running missions. I typically get around 40-50 fps when in lobby (not normal, my specs should be able to handle way more and I've set the FPS options in tweaker settings to be Unlimited) A little bit of stutter still exists in lobby but that's mostly fixed, though opening menus still cuts my frames by half. The glaring issue arises when doing missions. It's noticeable but not too bad when doing solo or 4-man content, but once it gets to MPAs and UQs, frames drop to 15FPS and stay that way. Playing on a laptop, with integrated GPU disabled by manufacturer by default.

My machine specs :

  • Nvidia GTX1070 8GB DDR5

  • Intel Core i7-7700HQ 2.8GHz

  • 16GB DDR4 RAM

  • 1080p 120Hz G-Sync display (Laptop screen)

Things I've done to try and resolve the issue :

-Set windows settings to use High Performance GPU for the game.

-Forced settings via the Nvidia Control Panel (PhysX using GPU, Prioritize High Performance for power settings and others)

-Turned off G-Sync, disabled Vsync

-Tried turning graphical settings to minimum, playing in fullscreen and various windowed resolutions .... nothing changes. Same FPS

-Disabled lobby video screens, disabled DX9Ex setting on tweaker. Limited FPS to 60/90/120/144, no dice.

-Clean reinstall of the game, did a flie check with the New Method on tweaker as well.

  • Clean reinstall and update of Nvidia drivers, which fixed stutter issues with my other games but did nothing for PSO2.

-Tried a fix on the official forums using Vulkan, a Linux variant of DirectX from what I understand. It worked and frames increased drastically in the lobby (except shopping area), but was getting weird lag when panning the camera while moving and ultimately it did nothing to solve the fps drop in missions. Link to post here : https://forum.pso2.com/topic/5163/ui-causes-fps-drops-na-client-runs-worse-than-jp/7

One thing I did note when using Vulkan, MSI afterburner showed my GPU being fully utilized while using DirectX it was only 35% utilized at best. Is this normal?

I'm kinda at a loss here. it's been happening ever since launch, but of late it's gotten really bad and kind of unbearable at this point. With the whole Vulkan switch it seems to imply it's a DirectX problem, but I have no clue how to fix that, running dxdiag it shows no problems.

I'm having the exact same issue. Some have suggested that even with the specs of my PC to lower the graphic settings just to get a better frame rate. And after doing that in 12 party urgent quests it drops to 20 FPS and outside of missions never tops 50 FPS. I've tried every suggested fix and nothing works.