Controller stops working after getting re-plugged (Solution Found) (Fixed)

As the title says, why does it do this? I have to restart PC everytime just to make PSO2 to detect it. Any other game detects it just fine after getting re-plugged. Sometimes it wasn't even my fault for it getting accidentally unplugged and this is the consiquences I have to pay for? Come on man. I've tried countless solutions such as using GLoSC (A program that makes you use Steam Controller settings as the universal controller) and it still doesn't work. Re-calibrating it on windows still doesn't make it work. Reinstalling or updating it on device manager doesn't make it work. Are there any actual solutions to this? this is getting annoying as hell, not to mention there is still a chance that PSO2 might also delete itself even when it was installed through Tweaker.

This is a Windows issue. For some reason, unless a controller is plugged in when the computer starts, it automatically gets detected as Controller 2, 3, or 4. This game can only read the controller if it is recognized as Controller 1. If it is re-plugged while the computer is still running, it will typically assign it to Controller 2, while something in the system takes over Controller Port 1 and doesn't let it go until a restart..

Well that fucking sucks. I guess there's no solution to get the controller back to Controller 1 either huh?

This post is deleted!

@CraigOrangeSoda said in Controller stops working after getting re-plugged:

Well that fucking sucks. I guess there's no solution to get the controller back to Controller 1 either huh?

Unfortunately, I have never found a way to get a controller back to Controller Port 1 without restarting the computer while the controller is plugged in. I could never even find anything about changing controller ports for controllers on Windows except for Windows 7.

I found a solution but it's more of like a soft reset

  1. Unplug Controller
  2. Sign Out or Log Off on Windows 10 (Go to Start Menu and click on your profile icon not the power button)
  3. Once you're out, re-plug controller back in
  4. Log back in and it will default to controller 1

Any program that you have on that you were using earlier, you're gonna have to re-open them yourself again just like on any PC Restart.

@CraigOrangeSoda Thank you so much for this! I couldn't figure it out. Even rebooting the PC wouldn't fix this for me. For some reason I guess unplugging it before signing out and plugging it back in before you sign back in totally fixed it. Its like some kind of black magic.

Its odd too because my old Logitech Gamepad still worked with everything else besides PSO2.

Really appreciate you coming back to your forum post to show the fix you found.

-Niric