Game crashes with "np0" error more frequently since update June 10th

Hi there!

So for the last week I have the "unexpected error occured" issue but with a simple "np0" error instead of "np1014" or "np1012". I contacted GameGuard and they gave me a list of processes to close, but that just broke the files entirely. First my "pso2.exe" was broken and after fixing it through tweaker GameGuard wouldn't launch. As I can't seem to fix that (tweaker troubleshooting options don't work at this point), I'm now downloading the game again.

A little bit more context for my "np0" problem:

  • it mostly happens when I play story quests
  • game crashes within 30-60 minutes after I launch a story quest
  • it doesn't matter if I continue to play the quest or abandon it and play something else, the game will crash
  • in other activities crashes are very inconsistent, sometimes right after login and at other times it takes up to 4hrs to crash once
  • so the "np0" error only happened in story quest before June 10th and happens outside of those more frequently since the patch is installed
  • after a crash GameGuard wants to send ERL-files from my C-drive even though it is installed on my D-drive
  • after a crash it seems like up to 4 instances of GameGuard are running, but as soon as I restart the game all except for 1 close themselves

Information about my system:

  • I use the pso2 tweaker to run the game
  • the game is installed on my D-drive, C is reserved for the OS and OS related programs only
  • my D-drive is the standard install location for windows apps
  • I'm part of the windows insider program and I'm in the fast ring (meaning I have an OS update every other week or so)
  • current build is 19645 from June 5th
  • Hardware should not be a problem, because the game worked flawlessly outside of story quests prior to the patch and I didn't update any drivers in the last two weeks

Possible solutions I tried so far without luck:

  • I tried whitelisting the entire "pso2_bin" folder as well as uninstalling my antivirus program
  • like I mentioned earlier I reduced the amount of processes running at the same time as much as possible (Gameguards solution) but it either didn't help at all or it broke the "pso2.exe"
  • I run the game as an admin and gave my user full permissions to the windowsapps folder on my D-Drive
  • lowering all ingame settings as much as possible

Does anybody have any ideas what else I can try? I made several clean installs this week and it didn't fix it. At this point it is pretty annoying for the game to crash right before the end of a Luther fight or mining base defense and it becomes more frequent.

I just got the same error while doing an Extreme Quest. I was doing Tundra & Automata stage 46-50, where stage 50 was a ??? stage. When I got to stage 50, it was getting ready to reveal what the stage mission would be, and then crashed before it could.

I've never gotten this error before nor have I had any other issues in the past, this is literally the first time I'm seeing this.

Edit: After this error occurred, I can no longer launch PSO2 (either via tweaker or default launcher), so I tried to restart my computer. My computer got stuck trying to restart and eventually blue screened before finally restarting.

Edit 2: So this error happened again today, seemingly at random. I'm beginning to suspect it has something to do with me using DS4Windows to use my PS4 controller on my PC instead of the Xbox 1 controller I had been using in the past. Especially considering the fact that once I get the np0 error, my controller just won't be detected, even after unplugging and replugging it via micro USB cable. The blue screen I get when I try to restart my computer after receiving this np0 error also may indicate an issue with the controller because the blue screen error is DRIVER_POWER_STATE_FAILURE. I never had an issue like this when using my Xbox 1 controller.

This error happens to me pretty regularly now, and it only began after the 6/10 Maintenance. Before that Maintenance i never had any issues with the Microsoft release of Phantasy Star Online 2 on PC, despite the numerous issues folks from all spectrums of PC setups have had.

I've just been one of those few fortunate who's only major issue with this launch was only the notorious lobby lag, but after 6/10, i'm now plagued by the "np0 unexpected error" bug, which affects more then just my PSO2 game from being able to relaunch again, but also Steam, some of my Art programs, and Adobe Premiere from launching.

I'm not at all computer savvy, and never have been; and restarting my PC seems to always fix this... whatever this is, but is this all GameGuard's doing? Because it's one thing for a game error to cause a game crash and perhaps affect it to properly start up again, but to then affect addition programs on my PC?

For the time being i'm not using Tweaker to launch the game just to see if perhaps this may be the culprit, but again, i'm not PC savvy, all i can do is report this stuff, test things on my own, and hope this gets fixed somehow, because it's getting disruptive enough to make me throw my hands up in the air and go back to playing other MMORPG's i don't really wish to play right now.

I've been having this issue as well. It's getting really annoying, just had it happen to me in a middle of a hardcore story mode quest. This is a large part of why I don't like Gameguard. It tends to be rather invasive and gets into issues like this.

So yesterday they pushed an update to adress some of the GameGuard Errors, according to their official Twitter page:

GameGuard Error Update

As I had no crashes yesterday at all, I hoped they fixed "np0" with this as well (I know they didn't mention "np0" specifically, but like I said no crashes in 10hrs), but today the game crashed twice again. In about an hour.

I made no changes to my system (no driver updates or new OS updates at all) so I don't know why it's so bad today, seems really random.

I'll try to reach out to GameGuard again, but I'm not too hopeful.

Hi! Our support is more than happy to assist you. Please submit a report about this issue to the link provided below. Apologies for the inconvenience. Rest assured that we are working hard in fixing all on-going technical issues right now. Thank you! Link: https://pso2.com/support#contact-us