Tweeker keeps asking me to go to the Microsoft store...

Just in case when you install the game only via tweaker and do the PowerShell thingy you should install Microsoft gaming services. If for some reasons it doesn't work like for me look at this : https://answers.microsoft.com/en-us/xbox/forum/all/xbox-pc-installing-gaming-services-this-may-take-a/8c1da137-4f0d-4159-b5d8-9089163c1269

And do what the first reply tell you to do and the game should work, if it doesn't work restart your pc and it should.

@DDDDLife I had done all of that with the initial install. It worked until the newest Tweaker release. Fortunately, working in IT, I brought my rig to work with me. Running repairs on my main drive through my work laptop now. Hopefully this will work, if not, I will just pull a backup of my files and reinstall. To be honest, it may have something to do with me installing PSO2 originally from the MS Store, even though I removed it. Something in the store may have left a corrupt entry that complete broke when the Tweaker it's update.

Operating systems...so easy to break.

@Wolf-Moonstar Yea, when I installed the tweaker, the guide strictly told me to make sure the microsoft installation was completely uninstalled, including going in the windowsapps folder and making sure everything was deleted. I checked every nook and cranny and made sure I was in Developer Mode before I ran the installation. I copy/pasted the command they gave me in PowerGuard; it did a bunch of things, and said it worked. After that, the game worked, and I haven't had a problem with it since.

I did try to install the tweaker while the microsoft version was still installed and it ran into a host of problems. It wouldn't surprise me if the microsoft store left some garbage in your PC after the uninstall.

@Wolf-Moonstar Hmmm... I would try and check for a BIOS Update First. Then give it a Go.

Didn't read any of the other comments yet but you're either:

  • didn't completely wipe the MS store installation for PSO2 (both the game data and the WindowsApp oxy back up)
  • Missing a few very important file that Microsoft pushes onto PSO2 EN because exclusivity require these MS store/Xbox Live files to access the game.
  • Best re-read and check your files over thoroughly, if any other issue arose, or persist, refer to the ARKs Layer discord (I will not post the server link).

@DDDDLife actually, they released a fix for the 6.0.1.5 yesterday. Read up and it said that in some rare cases the 1.5 bug would damage the registry when trying to repair PSO2. I got my OS completely reinstalled fresh so now any lingering MS Store garbage is gone for good. Reinstalling with the Tweaker base release now. Will install the 6.0.1.6 update once it finishes.

Ah, Mmmkay. Will definitely check it out.