Problem Regarding Microsoft Gaming Services

So i have a very weird problem that could be related to my region and the Microsoft App which is weird considering i can download the game in the first place by changing my region in the setting. I tried to make an install with the tweaker only because i've been told it's apparently safer and following the process you are told at some point to download the Microsoft gaming services. Which i tried to download but cannot for some reason, now i can't even see it in the store at all is it even possible that it is region locked but not the game.

What the hell is that even. Feel free to give me a link for the download because i do not seem to find any to see if it work it just doesn't work for me in the store no matter what i try. This also mean you can't do a custom path and since you can't install the game outside of your C drive that way you are screwed if you need to.

Edit: this is also a mini PSA for player outside US if you install the game do it via Microsoft store with the normal path but download the update via tweaker if there's no solution that should work.

Update: I am actually dumb i found a way to solve it

The Gaming Services is actually an additional runtime package time thing downloaded with games that require it from the Microsoft Store. You can't really get it any other way. The problem is that it is categorized in a category you can't search for called utilities & tools. You might be able to use a random game on MS Store to get it, but this is one reason why it is best to just download PSO2 directly from the MS Store and then use Tweaker to update it.

@Ragnawind Yeah i figured it was some hidden file shenanigans within the Microsoft store way too late and i was like what the hell is going on all the time since my Microsoft store actually broke (lol) while i was attempting to download with the tweaker program that allow the tweaker to run the game directly when you do a custom install and i wasn't able to re-access it after the process was done.