FIX UPDATE: Just use PSO2 Tweaker... Avoid the headache.

Guess the new update now bring a hole new set of issues again 'cause game's shutting itself after the intro... amazing

You really dont wanna people play the game maybe lol

@Marie-Poppo i have same problem.


And now i'm getting this, i tried the second option but i don't even know what "problem" with the Windows Store it means, there's nothing on the surface level that seems wrong with it.

Man i'm getting tired of this.

@AccelShift i got that same error when i couldnt log in to XBOX app, after i fixed the app it broke the game. Decided to give it one last go with Tweaker installation (JP client) and then using the NA-compatibility guide to register that specific installation of the game to MS store. Removed all of the game files from my PC 1st. Now my game skips going through MS store and launches directly from tweaker and recognizes my XBOX login on title screen.

NOw it's getting even worse after rebooting the pc, the game doesn't lauch at all.

And it's seems they are still on maintenance....

... i think sadly... i'm done with this game, i should had played on the JP servers instead really.

"You will need to set exceptions for the game itself. PSO2 utilizes an anti-cheat software known as GameGuard, which utilizes rootkit behavior to scan your running processes and files. You cannot disable or limit GameGuard's access in any way or form, as PSO2 will close if it detects this." - Uh... where/how do I set these exceptions?

@DarkTiggerXIII I allowed the exe's (launcher + pso2.exe) through the firewall and also added the whole pso2_bin folder as an exception to my anti-virus. No point telling you how/where to do that as all anti-virus are different unfortunately

@ScrawnyKitty all I have is the basic free Winfows10 antivirus/firewall package, no other 3rd party brand.

@DarkTiggerXIII Me too (on my laptop). Both are handled within Windows Security settings.

  • All Settings -> Update & Security -> Windows Security

  • Firewall - Double click Firewall & Network Protection -> Allow an app through firewall (top item in list at bottom)

  • Check the list - if both pso2.exe and pso2launcher.exe are missing then Change settings (top button) -> Allow another app -> browse to the location on your drive an add each one

  • Anti-virus - Double click Virus & Threat Protection -> Under Virus & threat protection settings click "Manage Settings"

  • Scroll down to Exclusions, click Add or remove Exclusions - I just added the whole pso2_bin folder as an exclusion and that then takes care of PSO2 + Gameguard

@Pheonixind said in FIX UPDATE: Just use PSO2 Tweaker... Avoid the headache.:

I can confirm, as PSO2 gets deleted every time I restart my computer. I will be changing over to the tweeker as well. I am tired of downloading the game every time I want to play it, over and over again.

Just FYI - for updates, this still happens. I haven't played in a day, downloading recent update and even with Tweaker you're forced to pretty much re-download everything. Looks like there is no way around this. If someone knows a solve, let me know. I've managed to avoid restarting PC, but updates trigger this issue again.

^Same thing happened here brother. The game worked wonderfully for over a week, then this recent update happened and bricked my install. Spent the better part of 2 days trying to figure it out. I went through the mind-numbing process of trying to uninstall. Reinstalled the game on the same drive I had it installed on before, hoping that it would use the files it wouldn't allow me to delete. Apparently it doesn't even recognize it's own damn files and proceeded to eat up almost 180gb of space to which now I finally managed on clearing up so that the files are now only around 12gb of hidden/locked down crap. Damn near ready to yeet this game. xD Doing one final reinstall and if that doesn't work I'll be putting in a refund for what I had purchased in-game.

I also had something really weird happen to me.

All of a sudden I got errors saying that I didn't have the rights to add these programs to my firewall or even access them. I can't even uninstall them from the programs and applications menu.

I'm really sorry, but I MUST simply beg the question... How?

...and while you folks keep trying, i know having some good time on the jp servers.

The only hoppe here is if they do decide a steam release aside of the sh.tty MS version.

right now since last monday i have no problems with the tweaker ❤ today is the 10th june and SEGA gave us a trubbleshooter guide...realy? SEGA needs 2 weeks for that shit statement? in this guide is nothing that works xD

IF SEGA gets the money with AC...they should give 75% of it to the arks-layer team

@Daigoji-Gai yep. I foolishly let windows 10 update and now im getting the file permissions issues. hoping the weaker solves this. Everything actually worked fine for me at release.. until this system update🙃