Seriously? Game unresponsive when attempting to launch.

I downloaded the game on the first day it was available. After attempting to download it multiple times it finally installed properly. This was the second time I downloaded it completely. It worked for maybe two days, or three or four separate instances of logging in before it stopped. The shortcut, start link, and play button from the microsoft store all became unresponsive. After jumping through hoops to wrangle the folder permissions from Microsoft I was able to delete the file folder and reinstall it. I launched it once briefly to test it, closed, then reopened it the next day (today) to try to play and am experiencing the exact same issue. This game has been downloaded three times, and successfully launched 3 out of 5 days I've tried to play it. This is incredibly disappointing. I don't want to be rude, the game is fun; but it's laughably bad how poor this launch has been and I don't know if I want to waste any more time trying to get it to work since it seems entirely random. Friends and family of mine have experienced the same issue and similar frustrations. It wouldn't be so bad if it wasn't 45 minutes of deleting folders and several hours of downloading every time.

Additional details:


Update: After spending a few hours deleting 140gbs of data hidden in a second folder I came across a few I couldn't uninstall. They wouldn't let me take ownership of the files and claimed the owner of the files were "system" I still can't purge this 21gbs of data. The Microsoft store hasn't updated to allow me to try one final install and hitting the play button started a download. I'm not sure where the files are going, but I hope it's not to my boot drive.

0/10 guys.