Friend and I can’t join a party together

My friend and I can’t join each other on the PC version.

We’ve tried forming alliances we tried changing our player ID and nothing at all has worked!

A lot of the forums are saying about having a player muted but that’s certainly not the vase

I'm having the same issue. No matter even if we are in the same block, I cannot join or start parties. I get the same issue every time, "You can't invite that player to your party at this time."

Yeah the mute glitch was my first thought. But considering it isn't that have you tried joining each other in the counter? Hopefully you haven't set your settings to private.

What settings can change privacy?

@Vorked When you go to the counter you can change if people can invite you or if you just automatically ignore them. I think it's under settings, and party invitations as well.

I have that disabled.

Yeah it's not working on my end either and i don't have that disabled neither is the chat working gotta reload the chat every time my friend messages no chat bubbles nothing only memes work in real time and i just got the game to work again.

Your Xbox Live privacy settings may also influence whether or not you can join a party or not.

Try going to your XBL account settings page here: and under "Privacy and Online settings" check for anything that is set to "block" that may be affecting your ability to join parties. (Not to be confused with XBL parties)

Had a couple of people in my alliance who couldn't chat and they found out they had a communication setting set to "friends only" and that fixed it, so it's worth a shot to double check.

All of those have been set to open and public, and haven't changed. Still not sure what is going on.

I would open up a support ticket.

I have, but it's gone without a response for awhile. I was hoping to see if community support would help fix the issue before. Was worth a shot, at least.