PSO2 Tweaker udpated today, game now black screens when launched.

Yeah... so... I updated the PSO2 tweaker a few hours ago.. and now the game just... black screens when launched. Anyone else having this issue?

I had same issue with tweaker after updating from version uninstalled update and reinstalled the 6.0.02 and went back to working fine, I've noticed tweaker has been updated several times since then and hoped they fixed the bug but with the daily frustration of trying to play this game I've yet to risk on other tweaker update.

You may want to try following these steps

  1. Delete or move the pso2.exe to a different location (ex. Desktop)

  2. Run PSO2 Tweaker.

  3. Start PSO2

  4. Let the Tweaker get you a new pso2.exe

These steps allows me to fix that issue

Must admit I'm getting in fine so haven't updated to the latest version.

Currently playing on my laptop but thinking of uninstalling the JP version on my main PC as it won't let me in - been years since I tried that version and kept coming back with a server issue. I tried a load of gobbledy-gook for my password as a test and got the same msg - so assuming it's an account issue for w/e reason. As I can't get into JP I think I might install the NA version on my main PC.

So not trying to fix it atm when it's not broken 🙂