[FIX] "Current User: No User"

Alright friends, being brand new to the game of course I ran into issues. Went over the forums, very little help, so I troubleshot my way through. Brute force style.

Here is how I fixed my problem:

  • Make sure the Xbox app is installed on your computer. Not the companion app, the actual Xbox app (it will say Xbox (Beta) on the Microsoft Store). See, I never used this garbage, so I had removed it from my computer. I had to re-download it.

  • Next, while inside the Xbox app, go to settings and Account, and sign-in. From here, go to General and make sure "Xbox Identity Provider" is not missing. Install it if it is missing. EDIT: It will not be there if it is not missing. You will not have a message!

  • Download and install the Xbox Companion app, this is needed for your friends list and profile management.

No reboots necessary.

Here's some optional steps I took to make sure my experience went smoothly:

  • Went to Xbox.com and signed in.
  • Went to pso2.com and linked my account with Xbox.
  • I did download Tweaker and pressed Update, but I don't believe this mattered or made a difference as my issue was Xbox related. Still, I want to include this here as it was a step I took in my troubleshooting.

Once you have done the above (excluding the optional steps), when launching the game you should now be prompt to sign-in using your Xbox account (I did not have the Xbox app or the Companion app running when I launched the game). You should now have your "Current User" be seen as your Xbox user ID. This account is easily managed using the Companion app, and I recommend that you do so.

Please let me know if this fixed your issue as it fixed mine.

EDIT: found it, PSO2 had a different account logged in from day1 but I didn't see that.

@Rvynn i dont have the identifier in my Xbox Beta app and cant find a download for it. if im looking under "services" i find a "Xbox Live Athenfication-Manager" https://www.xbox-hq.com/html/downloads.html is it this? This tells me where my Xbox was build but i dont have a Xbox, i want to play PC 🙂

Ill give this a shot cause boy it's frustrating being able to play once and that's it.

EDIT: If the micro store would stop lagging out that is =|
EDIT 2: Wow, yup that did it. Wth microsoft.

Thanks Rynn!

@TbnExotia said in [FIX] "Current User: No User":

@Rvynn i dont have the identifier in my Xbox Beta app and cant find a download for it. if im looking under "services" i find a "Xbox Live Athenfication-Manager" https://www.xbox-hq.com/html/downloads.html is it this? This tells me where my Xbox was build but i dont have a Xbox, i want to play PC 🙂

Hi friend,

I don't believe that is what we're looking for. The identifier is for logging in.

If you are signed in, and looking under "General" in your settings and you don't see the "Missing Identifier" message, then it is likely that you already have that critical piece installed. You could sign out of the Xbox app and sign in again, to see if this changes anything. You can also run the app as Administrator.

When I google any information about Xbox Identifier, I'm not getting anything that pertains to logging in with Xbox, but I found this was required to be able to sign into the Companion app. It is likely due to the fact that I uninstalled the Xbox app and had to reinstall it. But like I said, if you don't see it, it's not missing--the message is only there if it's missing!

Well then ... there is no hope for me until the officials here come up with the best solution there is.... independed game otherwhise we will never be able to play the game. : / its a joke that we didnt get any new updates in the last two days. No we have to wait till 10th june... 1.5 weeks!!!

@TbnExotia said in [FIX] "Current User: No User":

Well then ... there is no hope for me until the officials here come up with the best solution there is.... independed game otherwhise we will never be able to play the game. : / its a joke that we didnt get any new updates in the last two days. No we have to wait till 10th june... 1.5 weeks!!!

Can you tell me a bit more about your troubleshooting steps? What have you done already? Have you tried the optional steps I mentioned?

I'm curious if this matters or not, but do you live in the NA region for the port? I'm wondering if this might make a difference.

@Rvynn First. im from Germany, i set my PC region to US to download the Launcher. at first i could download about 170MB or so and got a fail 0x8007065E since then i get this error over and over again. I tried everything possible i could find online. i talked to 4 diffrent ppl from Microsoft for 5.5 hours and noone could fix it. Even they did everything possible from Store reset, new installation, Update Windows to 2004 version (went back to 1909 cuz there was the same error and one of my games didnt work anymore on this build) Friends of mine could download the game with no problem others got another errorcode. i guess me and my brother are the only two who get 0x8007065E while trying to download the game from the shit store. i looked at troubleshooting under windows and found this.nochfragen.JPG So its an error from the Shop it self and therefore they HAVE TO make the game INDEPENDED from the store. I tried to launch the game with a external Launcher from someone who uploaded his files. With this method i was able to Start, delete, patch the game but the missing Store connection prevents me from loggin in cuz there is "No User" and "Tab for switch acc." doesnt work.

Were you able to download the game and launch it?

Have you also set your Xbox region to NA? Even if your computer is set to NA, if your Xbox account is not also NA then you will likely run into problems as this is an NA port.

Their port is likely not optimized yet, most ports aren't, and issues like these are very common.

This actually work! Thank you so much for posting this