IMPORTANT READ THIS!!! 100% Fix that works PSO2 Tweaker Can solve your Problems It worked for me and many others. (NEW!! WITH VIDEO FROM Stone Legion - Let's Play)

Microsoft and Sega how much are you gonna pay me? I do more work then your Support Team! 😁

The problem for me right now is that I tried to start from scratch and install from ms store. However, Code: 0x800704C6 error occurred during download, and I noticed that my d/l speed dropped from 30Mb/s to something like 200Kb/s and eventually stopped resulting in that error. Haven't seen this problem before on my previous 3 installations.

I should give up now.... I restarted my pc, logged in again into everything . THE GAME JUST GONE! How can be the microsoft this sh@@@t..........

@Muleck4694 Let PSO2 TWEAKER check the files it will downlaod the missing files.

@DeeGeeGee thanks mate you are being really helpful.

Do you know if at least i will be able to choose in which folder i install the game this time?

@DeeGeeGee yes it will for 2-3 hours on my pc. I should really redownload again and again whenever i restart my pc? NO WAY! This is crap! I just wasted 2 day for this microsoft BUL@@T FOR NOTHING! thats it i give up..... maybe 2-3 month there will be an update with normal launcher and stuff, then i can play it to. Maybe....

@Muleck4694 wait, did you said that restoring the game files with Tweaker takes 2 to 3 hours? or i misread? XD

@Muleck4694 I am sorry to hear this. I tried my best to get you in game. I hope their will be a Solution for you soon! Have a nice day.

@Shrynne It depends on how fast your Computer is. My Specs

For me the it was very fast.

Bump Bump

so, i did everything by the book. when i open the game through the MS, it starts patching the 90k files again. wasnt that supposed to be download already? is it normal? should i just let i patch again?

@Wh1telaw Does it patch or just check the files? I would say just let it do whatever it does.

Ok guys i have to leave for now. If you search for help try it here:

ok... tweaker needs this shit of shit store connection... i tried to download again with a new created xbox account but nope same problem in the store with 0x8007065E .... @GM-Deynger Pls. bring us a solution.... dont wait for your higher ups and do something for your selfe or ppl will leave for good.

Account creation on your site Download from the Launcher from your site Login into the game by useing Acc. data created on your site.

will this pso2 tweaker fix this problem? it happened when i reset my pc pso2 error.PNG