PSO2 stuck in japanese

my came is stuck in japanese and dont know how to change the language just downloaded it from the microsoft store and its in japanese dont know what do do plz help

same issue here

hey had the same problem uninstall and install it again till you get the English version

Same Problem. Even i did follow PSO2 Tweaker Launcher (Tried the Original Launcher too, but still same Problem) too and updated there (With NA_Server), but still japanese Texts. Something is wrong with the Language.

I had this issue and don’t know if I fixed it or it fixed itself. I also had the tweaker installed. After closing the game I used the reset option in the main launcher, then checked that the tweaker was set to NA but didn’t change the options there but did change resolution and virtual full screen from the sega launcher. I relaunched the game and it was in English. As I said, I don’t know if it fixed itself or the reset did anything.

I think i solved the game Language. First, go to Language Setting: https://cdn.discordapp.com/attachments/542692519738212353/716196729707429908/unknown.png Second, change the middle one and choose the first one: https://cdn.discordapp.com/attachments/542692519738212353/716196775589052456/unknown.png You will get an unexcepted error [NP1015] and will close the game. Then open the Original Launcher and click "Check File". This takes a while. And then you can Start the Game. There you can read the English Texts.