cannot find msvcp140.dll

anyone have this error and know how to fix

Hello, i've got the same error as you and still have this error. Here's what i tried so far, maybe one of this work for you:

  1. Just download msvcp140.dll and put it directly inside your pso2_bin folder, if this doesn't work then delete it
  2. Reinstall every Microsoft C++ Redistributable then restart your computer
  3. Update Windows 10
  4. Check for missing files

am i missing something? so, if anyone know what else to do, please tell us.

i have the same problem here.. @Vainlife i have done to download msvcp140.dll and put it inside pso2_bin but still the same when i click start game.. number 2 : i have search that msvcp belong to microsoft C++ 2015, so i reinstall just 2015 and still can't play.. number 3 : i update to the latest windows 10, but T_T still can't play... number 4 tooo so how to fix this, i really want to play, and no one understand this problems i had T_T

yeah, i spent 12 hours trying to fix this and still nothing. This is supposed to be a simple error but somehow every possible solutions are not working. i even tried resetting my windows 10 at some point and still no result. I tried the unofficial pso2 tweaker because i can play pso2 JP without any problem 2 years ago with the same laptop but still can't play NA. My brain is slowly turning into mush at this point, i will just wait until someone can fix this. I'm not trying anymore, if nothing happens i will just move on and play another game. Good luck to all of you who had the same problem!

@Vainlife i think you have solved the problem, so how can i contact the pso2 (customer service or customer support) like emails? i think this post not read by develop or others

@Agcilia i don't even know if they have customer support or anything like that. I mean most of the major problems are fixed by another players anyway while the devs and microsoft did NOTHING but put out useless statement on twitter. You can try discord or reddit to ask for help, i've tried discord but their tech support is flooded so our problem might not even be read by anyone. It is amazing how they F up an 8 years old game this bad.

@Vainlife so sad, that pso2 can't help us to solve the problem.. yeah, i join the discord and ask in tech support, but too much chat from others, and no one reply my message lol XD i don't have the issues when play PSO2 JP, but my file got deleted so i try with NA server.. but got disappointed, really disappointed T_T

@Agcilia hey, i just submit a ticket here https://support.pso2.com/hc/en-us/requests/new maybe you can ask for their help too, i just hope we can get solutions as soon as possible.

@Vainlife thankyou, im done to submit a request.. i hope they can solve the problem soon 🙂