Nothing happens after I click play

What a horrendous process of trying this game to launch...

I successfully downloaded and installed the game yesterday, it successfully launched and downloaded additional files, afterwards I could launch the game.

Today I try to launch the game by clicking on the live tile I pinned to my windows start menu and nothing happens. Trying to launch through the microsoft store also doesn't do anything.

So I tried to uninstall my game, also nothing happened. Eventually the game seemed to have just disappeared, so I re-downloaded the game like 4 times from the microsoft store and then click play. The launcher pops up for about 5 seconds, I get a popup that the version is old or something and it will attempt to relaunch, then the launcher closes.

After that no matter what I do or try, when I click play the launcher never opens again. Any fixes?

Microsoft Store is absolute garbage. This has been an awful launch. I'm ready to just delete everything and go back to playing on the JP servers where strangely I never had issues even once..

Same thing is happening here. I was able to launch it just fine a couple of hours ago.

Any fix in sight?

I tried to uninstall and it sat there with the message "uninstalling...". Eventually rebooted my computer and found that PSO2 no longer appeared in my apps. When I went back into the windows store the button said install instead of play. I reinstalled and I'm back in now.

Same here. I had been playing for 3 days. Yesterday the game stopped doing anything.

Launching does nothing. Attempted to uninstall (from 5 different buttons: pso2 app screen, windows app screen, right click on the launcher) nothing happens. * I try to reinstall/repair from the microsoft store, nothing happens. *

  • = (When I say nothing happens, I mean I left it for 2 hours to try and do what it needed and nothing showed up. It took me 30 minutes to install the game initially)

The windows resource monitor shows PSO2 has been using 100% of my resources in resource history, but I cant find a process or service to cancel or stop running........