Stuck on title screen

Never saw that error sorry 😕

Just wanted to pop on and say thanks, I was having this issue for days but your advice of installing the xbox client fixed it

After looking around a bit I ended up getting the game running yesterday. Today, I did some more research to test some things and just wanted to share what I found out in case it helps more people.

The underlying problems that I found was the fact that to actually play the game you must have multiple different programs running. However, if you use a separate account than your administrator account you will start to run into problems due to varying access levels.

First off what is actually needed to play the game:

  1. pso2 from the store
  2. Xbox console companion from the store

The xbox console companion is what the game uses to get credentials from. Therefore, for the game to work you must be running the xbox console companion. Some people are also using the Xbox (beta) download. However, I tried deleting the xbox console companion and only using the Xbox (beta) application and I couldn't even run pso2 anymore. Therefore, it looks like the Xbox console companion is the only one actually needed.

The catch here is to download these applications while on your ADMINISTRATOR account. That means you have to physically sign in to your account that has administrator privileges and then install these and run them. If you try and install them using a local user account with no administrator privileges and just running as administrator it won't work. This is due to some permissions issues during installation which will cause all kinds of crazy errors.

Once, you have installed everything you should be able to run everything fine while on your administrator account.

The problem starts when you want to run it on your regular local user account as administrator. PSO2 will want to be ran with administrator privileges, however, the xbox companion has no way to be ran with administrator privileges. This means PSO2 won't be able to find your account and won't progress passed the title screen.

This is the main reason I can only play this game on my administrator account for my PC because it ensures that PSO2 and the xbox companion app are both being ran with administrator privileges and can access information from each other. In theory, you could use the Xbox (beta) app and run it as administrator and then use it to run PSO2 on a non-administrator account for your computer but the app crashes for me.

PS: In the search bar look for xbox live settings. Make sure server connectivity under xbox networking is connected. If not hit the fix button and restart PC. This should fix an issue with the network configuration.

i got nothing i tried everything so far

Nothing works...

yeah i dont know like i tried everything and checked everything

Same issue here. Stuck on the 'press the enter key" screen

@VendeeMan do you have the game downloadet from the store? if not there is no way to enter the game cuz its missing the shit store connection.

@TbnExotia where are trying to sign into xbox live from games start menu

@AvianPlanet306 i was loged in in everything i have... xbox companion app, x box beta but cant switch account ingame cuz i dont have the launcher from this fucking store there for there is no acc. on the title screen. Meanwhile im rly pissed about the incompetence what is here showing from Microsoft. -_- We waited 8 fucking years for this game to come west and now cuz of this fucking shit store which couses more problem then you can count we can't play at all or a lot of ppl. On top, now we have to wait 1.5 weeks to get a maybe solution from their site but the solution is simple as fuck i guess....

Just make the Game INDEPENDED from the shit store!!!!.

if u have free anti virus protection make sure u disable it cause the xbox permissions are blocked

@AvianPlanet306 i don't get a message from my anti virus that it has blocked something and if i look into the protocol, there isn't a log for a block either : /