"Change your settings to play"

https://imgur.com/a/KLcvM8N

How do I fix this? I've tried changing every setting I could find. If only the billion-dollar company that is Microsoft would be so kind as to add a button, a little tiny weeny wittle wutton, I could click to go to the specific settings they want me to change.

But no, that would be intuitive. Microsoft doesn't do intuitive.

Any luck? I've been stuck on this too. I tried changing the privacy settings every other post discusses, but no luck. I still can't get past the logon page.

I found this online for you, I hope this helps. https://answers.microsoft.com/en-us/xbox/forum/all/you-cant-play-with-content-created-by-other/0ee8db44-718a-4e38-9008-3103bd456159?auth=1

Hello, I tried to install PSO2 to my pc for 6 hours now, After finishing the download I launched my game and in the loading screen where it asks "Press the Enter Key" after I have done that another screen pop up and with a title said "change your settings to play" and the message is "you can't play with content created by other players because of how your account is set up. Go to your privacy & online safety settings on Xbox.com to change this" I followed this step and checked "Everyone" on the Privacy tab, "Allow" on "XboxOne/Windows 10 Online Safety" and Xbox 360 Online Safety. I relaunch my game and seem like it still did not works. There is no option to enable play games creates by other players. I've reinstalled the game and that did not solve the problem, I also tried to google the issues but seem like no one has a similar issue. So I'm posting this here to see if anyone has found the solution for this issue? The account is clearly shown as 18+ as well.

Resolved:

I changed the user during the "Press the Enter Key" and I was able to enter the game.

Hey Kro,

Appreciate the help. I've tried that. Got everything set to "Allow" and "Everyone", but doesn't seem to be doing anything. Followed all of the instructions on the other posts too, with no change. Might just have to wait till it drops on a different platform. I knew the Microsoft Game Store was bad, but I didn't realize it was this big of a dumpster fire. Thanks again.

@Howl4me I haven't had this issue, but it seems you are out of options currently (no offense) so could you try this?

  1. Go to Xbox.com and sign in with the Xbox account you use for PSO2.
  2. Find and click My Microsoft Acccount Microsoft Account.jpg
  3. Click Privacy Privacy.jpg
  4. Scroll down to Apps and services and open Apps and services.jpg
  5. Is there an service called oxnya? Edit and remove this permission Oxyna delete.jpg
  6. Restart PSO2 and hopefully it gives you a window to log in and play!