"Change your settings to play" "You can't play with content created by other players"

Screw microsoft, it was working before not it isn't. im going back to JP and ES

So, i started having this issue overnight and after days of banging my head against it, trying every fix suggested here, on reddit and by the ticket support, and even calling MS support, i finally figured out a fix that worked for me:

  • Make a new MS account that is over 18.
  • Go into https://account.microsoft.com/ with your account that's having the issue and edit your birth date to make it so you're under 18 (17 is fine).
  • Log into your newly-made account and invite your main account to a family (as a member, not manager).
  • Accept the invitation with your main account and now you have a family setup.
  • Go into the xbox profile privacy settings with your alt account, the manager of the family.
  • Here at the top you'll see you can manage those settings for members of your family as well, in this case your main account.
  • Turn every setting in there (on both tabs) to blocked and then back to everyone
This post is deleted!
This post is deleted!

I've tried everything here and nothing worked for me. Unable to login with my account but a fresh new account (with the exact same settings) works without issue for logging in. Any other suggestions?