"Change your settings to play" "You can't play with content created by other players"

I didn't find any related threads so far, apologies if I missed it (I did use the search).

I'm finally able to try and start the game after installing the Xbox and Xbox companion apps from the Windows Store.

However, now the game tells me:

"Change your settings to play

You can't play with content created by other players because of how your account is set up. Go to your privacy & online safety settings on Xbox.com to change this."

Of course it doesn't, let's say, give you a direct link. But I logged into my Microsoft Account and Xbox.com and changed my privacy settings to their most permissive. And yet the game still won't start.

What specifically does the setting it wants changed looks like? God forbid they show an example. Untitled.png

If this is the page it's referring to:

https://account.xbox.com/en-us/Settings?rtc=1&wa=wsignin1.0&activetab=main:privacytab

I allowed it all so I'm unsure what else to do.

This worked for me.

Went to Microsoft account and selected privacy tab at the bottom of the screen I went into "apps and services that can access your data" look for "oxyna" and remove permissions restart PC and run PSO2 it should ask you to re login to your Xbox Live account and then for permissions

not sure if this was a fix or I just got lucky

cheers

@Tonestryker said in "Change your settings to play" "You can't play with content created by other players":

ent to Microsoft account and selected privacy tab at the bottom of the screen I went into "apps and services that can access your data" look for "oxyna" and remove permissions restart PC and run PSO2 it should ask you to re login to your Xbox Live account and then for permissions not sure i

Where? What privacy tab? On the Microsoft website? On the Xbox.com website? In Windows settings? There's like a billion privacy settings.

I couldn't find it either, but I was able to access it from the email I got when I originally allowed access. The link goes here:

https://account.live.com/consent/Manage?fn=email

I was able to remove the access from that page, but I haven't re-tested logging in due to the other issues the launcher is having.

I also have the same issue.

I've tried removing the permission access and re-accepting it again, but it did not fix the issue for me.

I've tried looking through Xbox/Microsoft Account and Windows 10's privacy settings with no luck figuring out what is causing this issue.

@Th3-Uniqu3 said in "Change your settings to play" "You can't play with content created by other players":

@Tonestryker said in "Change your settings to play" "You can't play with content created by other players":

ent to Microsoft account and selected privacy tab at the bottom of the screen I went into "apps and services that can access your data" look for "oxyna" and remove permissions restart PC and run PSO2 it should ask you to re login to your Xbox Live account and then for permissions not sure i

Where? What privacy tab? On the Microsoft website? On the Xbox.com website? In Windows settings? There's like a billion privacy settings.

I think they must mean:

https://account.microsoft.com/privacy/

and then "Apps and Services":

Microsoft_account_Privacy.jpg

Which I would have never found on my own because MS has too many settings.

Tying this to Xbox/MS is extremely frustrating. It reminds me why I try to not even buy Steam games now. Every walled garden is a pain in the ass.

I can't reboot right now, but I'll try the above suggestion tomorrow.

@cecoates (Edit: I overlooked it) It is indeed in there https://account.live.com/consent/Manage?fn=email , so I tried removing it.

Can't test it yet as I uninstalled it yesterday out of sheer frustration. This is the third error preventing me from accessing the game. I sincerely hope the developers intend to do something about this because it's insane how many problems there are just from looking at this forum.

Woah it actually worked. I can't believe it. We're in the main menu. Can't wait for the next error.

@Th3-Uniqu3 said in "Change your settings to play" "You can't play with content created by other players":

Woah it actually worked. I can't believe it. We're in the main menu. Can't wait for the next error.

😂

I finally got it to work for me, found the solution on a gamefaq post.

Have to make sure to set the Xbox Live account privacy settings "You can see and upload community creations" to Everyone, setting it to Friends or Block will cause the privacy pop-up window.

ebb2eb71-921a-4d9e-b75c-30e962526d81-image.png

@mazebXB I still got the error long after changing those settings, which can mean one of two things:

  1. This setting doesn't fix it. OR
  2. It doesn't take effect/notice the change until you re-add that oxyna thing to the permissions/privacy settings mentioned above.

My money's on the latter. Hope that helps someone.

@mazebXB said in "Change your settings to play" "You can't play with content created by other players":

I finally got it to work for me, found the solution on a gamefaq post.

Have to make sure to seet the Xbox Live account privacy settings "You can see and upload community creations" to Everyone, setting it to Friends or Block will cause the privacy pop-up window.

ebb2eb71-921a-4d9e-b75c-30e962526d81-image.png

Where do you go to find that

@CyborgninjaDMX i just found this page and here's how. when you get redirected to this screen kokl.PNG

press home at the top kokl home.png

then at this screen under you gamertag and pfp press more actions j.PNG

form there select xbox settings and you'll be brought here. select privacy and online safety. ae8250e1-a208-421f-b785-a729e801786a-image.png

then select xbox one/windows 10 safety and your done.

Not sure if this works yet.

Edit: it doesnt work

This post is deleted!

windows settings > Gaming > xbox networking.

Then click fix it > restart pc > Click Fix it again until the nat type / server connectivity both pass.

This worked for me!

xbox networking.png

xbox network fixed.png