FIX HERE: GAME WON'T RESTART

Thanks, this was really helpful. It’s annoying that problems are still occurring even after a month since the pc launch.

So they still haven't fixed it? Oh, well. I'll just treat this as vaporware.

Same here now.... Game doesnt launch anymore. This is ridiculous... I was going through lengths back on Dreamcast to get JPN version account on an EU console, learned Japanese to play the other PSOs and now 20 years or something later i thought i finally be able to play without headache. Seems not... Here ive spent around 10h already just to install the game. Now it doesnt run anymore and im afraid im out. Have better things to do.

For how much this game breaks or suddenly stops launching, they should be giving players free ARKS Cash as an apology, especially those of us who paid for the Ragol Edition and have Premium time being wasted by all these issues. Been playing just fine for 2 weeks now and suddenly it won't launch from the MS Store. It's in a downloading loop with no progress being made. I even deleted the game folder to try it with a fresh install and it still just sits there downloading nothing.

Could anyone let me know why this pop-up keep saying "This product is not supported by your environment"? I'm from Australia and my PC is fine normally.

@VoxProject-0 Check to see if Pso2 was even release in your area, it could be Aussie law becuase of the loot box and other things.

not work start yet pso2gn2021-06-27 (1).png image url)

@Daigoji-Gai said in FIX HERE: GAME WON'T RESTART:

@Pairamedic For some it does. The app gets corrupted easily.

I was having the same issue, tried to start the game, game failed to start, bug report box popped up a few seconds later. Tried to send the report and the bug report box froze up and quit responding, couldn't even close it with task manager. As I type this I am still unable to close the report box. I did an integrity check on the game files, and now am in the process of "reacquiring" 89.9 GB of game files via steam platform. Game ran fine until yesterday when it had a very small update (I think it was less than 100MB). Not sure what the update was or what it was supposed to "fix", but it did not agree with the steam files at all. Now I have to wait for my slow ass internet to download pretty much the entire game again......