Failed to download the latest version

Even after I change permissions, uninstall, reinstall in different locations, nothing seems to work. Anyone find a fix for this error? WTFPSO.png image url)

I am hitting this issue as well - I've been fiddling with this for hours. I've concluded it's due to the client pulling files to the C drive before putting those files in the correct installation folder - as my game client filled 19GB of space (the amount I had left on my OS Hard drive) before hitting this issue.

I've been having this issue too. At first, I thought it was due to insufficient disk space, so I removed almost all the software on my computer to an external hard drive to be sure that wasn't the case- still fails. During my investigation, I discovered that when a download fails and restarts, it doesn't pick up where it left off or remove the old download; rather, it keeps the files from the first attempt and starts a new. After going into the files and deleting all the first attempts, I thought this would solve the lack of space but it failed yet again.

I have no idea what the problem could be. What baffles me the most is I managed to get the game working this morning and even played for a few hours with a friend without issue. (He has no problems getting his game to work.) After closing the game, I later tried to get back on but the launcher forced a redownload and that's where problems began.

I think the file in the error message might be corrupt and this a problem on the developers' end.

My error messages: I received many more of the same type but this is all I documented.

Failed to download the latest version. Please wait a while and try connecting again. Filename: data/win32/c1726667b2af7fcd58649f1c227589bd.pat Error: 17 {No. 140]

Failed to download the latest version. Please wait a while and try connecting again. Filename: data/win32/994e82cb256ba7c1ccef72f0ac350ffd.pat Error: 34 {No. 140]

is the game installed on your C drive ? are you useing the required drivers for windows : Windows 10 version 18362.0 or better when you check devices does it show 1 or more on your account if so delete the old one only if you have 2 + the game trys to load the old one as a main and that crashes the launcher

I've been playing fine the past day and logged off. Came back to this when i tried to log back in...