Windows 10: Issue with xgameruntime.dll

After clicking the start game button, the gameguard splash screen loads but then dissappears and nothing happens. When checking the windows application logs I found the following error message:

  • <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  • <System> <Provider Name="Application Error" /> <EventID Qualifiers="0">1000</EventID> <Level>2</Level> <Task>100</Task> <Keywords>0x80000000000000</Keywords> <TimeCreated SystemTime="2020-05-27T19:28:29.129216000Z" /> <EventRecordID>9036</EventRecordID> <Channel>Application</Channel> <Computer>DESKTOP-26SQN3J</Computer> <Security /> </System>
  • <EventData> <Data>pso2.exe</Data> <Data>0.0.0.0</Data> <Data>5ecbe8f6</Data> <Data>xgameruntime.dll</Data> <Data>10.0.19041.1870</Data> <Data>4cf7c9be</Data> <Data>c0000409</Data> <Data>00000000000f6492</Data> <Data>e54</Data> <Data>01d6345cfba9f26b</Data> <Data>C:\Program Files\WindowsApps\Mutable\100B7A24.oxyna_1.0.7.0_x64__wyfsmff9ynw7j\pso2.exe</Data> <Data>C:\WINDOWS\SYSTEM32\xgameruntime.dll</Data> <Data>c73cba7b-a3c8-4942-bc53-c095b169894e</Data> <Data>100B7A24.oxyna_1.0.7.0_x64__wyfsmff9ynw7j</Data> <Data>Game</Data> </EventData> </Event>

I'm receiving the same problem in the Event Viewer.

I've Tried:

  • Reinstalling (Several times)
  • Check Files
  • Replacing said .dll with another copy found online.
  • Taking ownership & full control of game folders
  • Ensuring all XBox Apps are installed
  • Disabling AntiVirus & User Account Control

All with no success so far.

I've got the same error. Game installed without issues and ran the first time launching. After changing resolution, I haven't been able to launch the game again. Restored all graphic settings but still no luck. Tried giving full permissions to pso2_bin folder but the game still does not launch. However if i run the pso2launcher.exe in that folder the game runs but comes up with no user and I get no response trying to switch user or pushing any key. Pretty frustrating and a pretty poor experience for me who has just heard about the game a couple of weeks ago.

Just attempted to let the "Repair" option on the app after a fresh install. Normally the full download and install process takes about an hour - this "Repair" feature ran for almost 3 1/2 hours and did nothing to help.

My issue was finally resolved. I have an Alienware laptop and there are a few Alienware applications that are running like the Alienware FX and Sound Center. Shutting these items down in the task manager has allowed me to get into the game.

@Datura359 said in Windows 10: Issue with xgameruntime.dll:

My issue was finally resolved. I have an Alienware laptop and there are a few Alienware applications that are running like the Alienware FX and Sound Center. Shutting these items down in the task manager has allowed me to get into the game.

Same here. I closed nearly every app i had open in my system tray and now the game loads. I'm not sure exactly which app was causing the issue but the game now loads so i'm happy.

Got the same error. Closing every app didn't helped at all. If any GM could provide a durable solution I'm listening...