Fixed it!

After several hours I got it working. First try disabling all antivirus, if it lunches then add an exception to your antivirus if not.... here's EVERYTHING I did, I don't know 'which' part did the trick.(not worried about typos i wanna hurry and FINALLY play).

  1. Update Windows 10

  2. Uninstall PSO2, uninstall might be corrupt ("MS store, It just works!"). 'When' the uninstall hangs let it hang for about 10-20 minutes and reboot. If its gone continue if not try again but wait longer.

  3. Delete 'Mutablebackup" with this guide to reclaim HDD space, unless you don't care, then skip?? I did it tho: https://www.reddit.com/r/PSO2/comments/grim8e/troubleshooting_if_your_launcher_does_nothing_or/?utm_medium=android_app&utm_source=share

  4. Disable all antivirus until the very end of the remaining steps

  5. Reinstall PSO2 with the Microsoft Store App on your programs menu, NOT a browser.

  6. Launch app and wait for the really long download.

  7. During the download I added 'Administrators' permissions (see step 3) to the new App files located (for me) in > C:\Program Files\WindowsApps\Mutable

  8. Still with my antivirus off I tried launching twice, second time it started working. Then I turned 'off' silent mode on my antivirus which allowed me to an an exception for my antivirus. whew okay good luck! ^-^

@Hownztooth Thank you! Disabling AVG got me into the launcher for the first time after hours of troubleshooting!

Is your antivirus Avast, by any chance? I'm not too keen on reinstalling the game for the third time (takes a few hours each time) unless I know we're at least using the same antivirus