[CAN'T INSTALL] ''Try again later something happened on our end.''

alt text I can't even install it from microsoft store. My region is NA. Already wsreset.exe my microsoft store and cleared cache. Already troubleshot and it found nothing. I really don't know what to do... please help me if you have any clue

Yeah man I got the exact same thing, but nothing has worked so far.

right there with ya lads. I've been on a support call with microsoft for 2 hours for them to just put me on hold and hang up..

Welcome, we arent the biggest club in the land of PSO2 bugs, but we do exist!

Im sad to say that there doesnt seem to be an easy answer for this one. I've tried all the google "fixes" and even done some command line digging to no avail. It feels like there is something inherently wrong with our microsoft windows 10 images or the server that pushes the download for PSO2 is shot. I'm very confused myself because I can download other apps fine but this one in particular won't work. Sadly these forums haven't helped one bit either and Im sorry I can't really give you more than what google would.

I decided to make a T-shirt concept for our club between download attempts: 1c50dd03-7c66-4002-bd91-a5ff11888302-image.png

I am confused since it happened both on my desktop and laptop... Also tried using my smarthpone 4G connection to install but still the same issue. I am out of ideas guys, will we be saved? 😧

i'm about to just rebuild my windows profile to see if that can fix it. i know my M$ account isn't the problem so i'm trying to wipe out any cache that could be getting in the way.

yeah I think formatting can be an option. Either that or we might for some reason have a timeout.

@LucaDGV I think formatting is the only option since we don't have an alternative way to obtain the launcher

it is so silly we can't install this as a standalone... Format can be a soluation yeah...but I can't really do it since it is also my workstation for freelance work sadly

This is clearly something wrong on the Microsoft store, just wait for Sega to respond before spending so much time troubleshooting.

If someone formats and can confirm that fixes it please let us know. I would have to start backing up my info.


Do a restore point to any date before today. You are very welcome.

OMG I did it and that actually really work ! @LucaDGV Thanks so much man I can finally download the launcher and start downloading the game ^^ Fingers crossed for the next steps now!

RIP, I wish I had done that before doing a full system repair. That didn't work for me.