Akako has figured out how to get 4k (and other resolutions)

Go here:

C:\Users\akako\Documents\SEGA\PHANTASYSTARONLINE2_NA

Then open "user.pso2" in Notepad. Look for Windows and edit the Height and Width to these settings or just copy paste what you see here. I am now running the game in 4k.

Windows = {
        FullScreen = true,
        DisableDirectX9Ex = false,
        Width3d = 1280,
        Height = 2160,
        Height3d = 720,
        VirtualFullScreen = false,
        ManagedDevice = false,
        Width = 3840,
    },
}

This is awesome! Works great! Now...how do we increase the font/UI? There's this section: Screen = { InterfaceSize = 2, MaxScale = 1, PreferredScale = 1.4, ReferenceResolution = { Y = 720, X = 1280, ...but I don't know what to do with it. Changing Preferred Scale didn't seem to do anything. Thoughts?

what settings would I use for 1440p? i'm confused about the width3d and height3d

@ConnectedGhost said in Akako has figured out how to get 4k (and other resolutions):

This is awesome! Works great! Now...how do we increase the font/UI? There's this section: Screen = { InterfaceSize = 2, MaxScale = 1, PreferredScale = 1.4, ReferenceResolution = { Y = 720, X = 1280, ...but I don't know what to do with it. Changing Preferred Scale didn't seem to do anything. Thoughts?

I'm curious about this also. Been messing with those settings and nothing changes

Here's what I'm running to get 4k

Windows = {
    Width3d = 3840,
    Height3d = 2160,
    DisplayNo = 0,
    Width = 3840,
    DisableMemoryOptimize = false,
    FullScreen = true,
    Height = 2160,
    VirtualFullScreen = false,
    DisableDirectX9Ex = false,
    ManagedDevice = false,

The above setting with give you 4K but the UI is super small. To fix the UI I did the following:

From the launcher under Environment Settings I select the Screen tab and change the preferred scale to 1.5 under text size. I don't mess with anything else. Save settings and the UI is larger.

Here's what you'd want for 1440p

Windows = {
    Width3d = 2560,
    Height3d = 1440,
    DisplayNo = 0,
    Width = 2560,
    DisableMemoryOptimize = false,
    FullScreen = true,
    Height = 1440,
    VirtualFullScreen = false,
    DisableDirectX9Ex = false,
    ManagedDevice = false,

For 1440p you may want to change the preferred scale to 1.2

Hope this helps

EDIT If you're running the game on a 2nd display like me I also have to change DisplayNo = 0 to DisplayNo = 1

@SmiggyG It seems like the UI is still far too small with the 4K option and using the 1.5x multiplier. Any suggestions for increasing it beyond the 1.5? Even updates to the user.pso2 seem to not result in any noticeable benefit.

Yeah unfortunately even the JP game they didnt make this game suitable for 4k players with the UI.

PSO west really needs some 4k options for bigger text

I've been playing in 2k, text is nice and legible seems like an ok trade-off for now.

Why the hell do we need a work around for this? I'm forgiving, but these are basic functions that have been in PC games for years.

Sega/Microsoft... the help guys?

@Kulvir Nah that's the biggest when running in 4K 🙁 I haven't figured anything else out. It's very comparable to my UI/font settings on the Xbox One X. 1440p at 1.5 might be a better option for you.

On Xbox One X the text is perfect 4k on pc is awful. This would be an easy fix for them to add to PC

Are you all sure it is 4k? When you press print screen, what is the resolution of the image captured? Mine is still 1920 x 1080 with the above settings edited? Try it and see.

Use PSO2 tweaker its out now.

@Vex7179 IDK my display reads it as 4K 60hz. If I change it to 1080p my display says 1080 and it looks worse. Without counting each pixel I can't say for sure.

Also as far as Tweaker goes theres' not a 4K option though.

Which is weird. The Xbox One version supports 4K. Why doesn't the PC version?