BSOD Crash when pso2.exe starts

Hey there, when I (attempt to )start the game, I get a black screen after the nprotect gameguard. On the black screen I can see my cursor with the loading animation and then it freezes. Afterwards I get a BSOD with critical_process_died.

It's very odd, and I have tried googling everything that could be wrong.

Things I've done:

  • Disabled anti virus/anti malware (only got windows security & hitman pro alert).

  • Ran SFC /scannow to check for corrupted system files.

  • Updated Windows.

  • Tried different games.

Only with PSO2 do I get such a strange crash. I very well might be the only one who has this issue. Nevertheless it is very clear that the game has some major issues... I wonder if someone knows how to solve this particular BSOD issue with PSO2 at least.

Have you tried reinstalling or installing it to a different drive?

Not sure how many microsoft store games you own but it could be an issue with how the install went, lots of bugs surrounding just the store itself. If you havent reinstalled it to a separate drive or something give that a go and see. if not I guess your computer is allergic. not much I can say. Just a suggestion

Forza Horizon 4, which is also a store game, works fine on my PC. I have a bad experience with installing store games on a separate drive. If possible, I'd like to refrain from doing that as it can be a major headache when you want to delete software. I'll try reinstalling again, if it doesn't work, well nothing gained and nothing lost.

I have the same issue on my PC exactly as described. Have uninstalled and reinstalled 3 times now once on a separate drive but the issue persists. My rig meets the requirements to play by quite a bit and PSO2 is the only game that crashes with a BSOD. Oh well back to FFXIV.

This post is deleted!

Followup to my previous post. Still have not got PSO2 to run without a BSOD after game guard and black screen. I have tried the suggested fixes and use PSO2 tweaker with no sucess. I am a windows insider on the slow ring running windows 10 pro version 19041.264. Are there others with an insiders build that are able to run PSO2? Just curious.

I've had this problem in the past with JP versions of the game. You're blue screening because of Gameguard. Gameguard is not compatible with Insider Preview versions of Windows 10. If you want to play PSO2 you need to roll back from whatever insider preview ring you're on.