FIXED error 1813 / Launcher Update Loop

@Acelium https://gist.github.com/HybridEidolon/b809b1ac781c18461b8106da402c8f18 A fix is located here, along with various other solutions for this game. Check it out.

It worked for me. Thank you so much

@Acelium said in FIXED error 1813 / Launcher Update Loop:

Im curious now. How many of you have been from outside of NA/Canada? Asking this since about 10 of my friends have installed the game and only one of them had these issues and they are from EU.

Lul, would be funny if all that mess is region based ) But, yes, im not NA/CA resident.

So, it kinda worked for me, but it required a little more tinkering: after allowing my windows user to gain control over the file, i had to "disable inheritance" and delete all the permission entries, to add SYSTEM and MY USER permissions manualy afterwards.

xxxxxx.png So my launcher finally stopped looping, but after I click play on the launcher this happens in my task manager.

I'm guessing this is still a permissions problem? I was unable to change any of the permissions 😕

Can't change anything stupid Windows bullshit. I have no permission and tells me about error... This is the worst game start ever for me... frusttrating I just got 2 weeks off and it seems my time will be used finding a solution to play PSO2.... Thanks Windows for making it really hard.

@CthuNoCold I Love you!!!!!

@Voltm dont love him to fast. after 5 hours i restartet my computer and the files are gone. this launcher is trash

Both files PSO2.exe and otp_notice_na.rtf are now both administrated by me with fully rights, still gives me error 1813...

How they hell i'm supposed to remove MutableBackup? Since it's hogging 170gb of PSO2 corrupted installation files for no reason i was forced to download over 200gb at this point and still can't play.

treesize is a good program to uninstall fails

@VLP-Siliarus said in FIXED error 1813 / Launcher Update Loop:

I seem to not have been the nly one running into the issue of "LastError: 1813" and complaining about the file otp_notice_na.rtf, as seen here https://lowee.de/2020-05-27_14-23-37.png and followed by the launcher going into a loop, erroring out again https://lowee.de/pso2launcher_2020-05-27_14-16-11.png

I was able to get out of this by (temporarily) disabling Windows Defender AND specifically changing the File permissions for "C:\Program Files\WindowsApps\Mutable\100B7A24.oxyna_1.0.7.0_x64__wyfsmff9ynw7j\otp_notice_na.rtf" as well as pso2.exe - THIS FOLDER IS A LINK TO YOUR ACTUAL INSTALLATION DIRECTORY! So it doesn't matter if it's actually installed somewhere else.

To update the permissions, you first need to take ownership of the files and then add your user to the list of permissions. I also did this for the data subfolder and its contents, but i don't think that is necessary.

TO DO THIS:

  1. Go to the above mentioned folder.
  2. Right-Click the .rtf / .exe file
  3. Properties
  4. Security
  5. Advanced
  6. Edit
  7. Advanced
  8. "Search now"!
  9. Doubleclick your user or a group you are in Image
  10. confirm the dialogs
  11. Check "apply to subfolders and objects"
  12. apply
  13. Reopen the advanced security dialog
  14. You SHOULD be able to click "Add" now
  15. search for your user
  16. Full Access
  17. Apply

Repeat this for any files the launcher may complain about.

Hope this helps!

See you ingame~!

i can not enter my own folder "WindowsApps" because i don't have permission? I hate windows. Will probaly wait for steam release.

Nothing posted here helped me. If I solve the problem with permission, then, the thing ask me for the opt_na_blablabla, when i solve it, it ask me for .dll. I cant find it anywhere, so i try to search it in other places, and nowhere to bee seen. AND THEN, anything works, i cannot enter the launcher or the game deletes itself.

I suspect this happen to me cause i have 2 drives, and C : is to small to handle it, and, furthermore, the first 11GB are downloaded there, even when I click on download on D:. Im starting to get tired after an entire day of delving in files and using obscure stuff i never needed to do in other launches.

This is a mess, and i dont think Sega nor Micro will give us a solution in the near future. Heck, even if you enter the game, all servers are full, and if you restart you computer the game will dissapear.

@VLP-Siliarus all, dont mess with the permissions. Just disable UAC and run the game in admin mode. It will work

@Chrystalian Yea i found that post few minutes after i got my game fixed.