FIXED error 1813 / Launcher Update Loop

I gave up on this, not worth the time to have to fix something. I was having the same issues, and found that it was some issues with another download coming with the game (called Game Services, probably was an update). I forced the game to download ahead of that service and it went well, opened up the patcher and went well till 60% (was hella slow) till it gave error, after the game didn't want to run anymore.

I searched all around for solution till I bumped on someone explaining how to use the repair function of the windows shop, so I went with it, took 3 hours for the whole checkup (the game was installed on a M2 with somewhat decent speed 3000 read 2400 write) just to return an error, not repair and simple remove the whole game installation.

I wish good luck to who persevere on this, but I won't waste my time on this, and as a lesson, this will be the last time I install games from Windows Shop, this UWP crap is really nasty for gaming.

@CthuNoCold The missing DLLs may be coming from a seperate download the game should kick off when installing it from the windows store.

I was going to come here and curse about this being not helpful but then i noticed that i edited the permissions on wrong file. Will update if it helped

So the fix worked but its complaining about the vivoxsdk.dll.

cant you all see how stupid this is? We dig deep into the PC Folders because this trash is not working and changing stuff we shoud not change lol. Just to start a Game that even never shoud have this problems xD


Well the thing is that some ppl are having these issues and some are not. Few of my friends were able to install and launch the game without issues

The Problem is, the Devs do nothing to help us

I downloaded game. Got problem 1813, fixed it with your solution. Everything worked. After this I gave the game final test. Restarted PC. And.... I can't launch pso2. Like tottaly, and after this all my downoaded data automaticaly dissapeard from my pc. Thanks windows store. Devs should fix, not us.

@VLP-Siliarus True enough, that what i was meaning in "some third party software that game did not include in its parts" part )

@Chrystalian said in FIXED error 1813 / Launcher Update Loop: You can acquire the dll file here

I'm pretty sure that almost all of us actually do have that dll in correct folder, game do download it within it's updates, but i think it's just not enough to have that dll just by it self, it should be a part of something bigger, much like often you can see that Microsoft Visual C++ redistributates does when you install almost all of newer games now. Because i have tryed to manualy register it with regsvr32, but no luck at all...

Also, found solution for vivo dll in other thread:

@Morkalith said in Windows 10: Vivoxsdk.dll is missing:

I found a fix that worked for me:

  1. Open PowerShell
  2. Copy this and press enter: cd "C:\Program Files\ModifiableWindowsApps\pso2_bin"
  3. note: change "C" for "D" or the disk where you installed the game
  4. Copy this and press enter: Get-Acl pso2launcher.exe | Set-Acl pso2.exe
  5. Copy this and press enter: Get-Acl edition.txt | Set-Acl otp_notice_na.rtf

Hope it works for you guys.

Thanks to @Morkalith

WTF I don't have "C:\Program Files\ModifiableWindowsApps\pso2_bin on my pc" owo

we should stop trying to hot fix , this is not our job . i know we all want to play, but we dont need to do PSO devs ( or Microsoft store who knows) work. this is a complete disaster at this point.

@I-UsagiTsuki-I said in FIXED error 1813 / Launcher Update Loop:

WTF I don't have "C:\Program Files\ModifiableWindowsApps\pso2_bin on my pc" owo

Three options i can see:

  • you changed installation hdd, so solution is to re install with default settings
  • you haven't checked permissions on game folders and files
  • you have to wait until official solution)

Im curious now. How many of you have been from outside of NA/Canada? Asking this since about 10 of my friends have installed the game and only one of them had these issues and they are from EU.