PSO2 Title Screen - Press Enter Key

It will not let me get past the Phantasy Star Online 2 title screen. I hit any key to continue and it reloads the title screen animation.

I am signed into Xbox Live Account on the PC. Do they have a stop in place to prevent PC users from going any further?


Had this issue as well. Haven't seen any solutions offered up yet.

I thought I read a scenario where if you forcefully uninstalled Xbox Live components from Win10, this behavior can happen since it's failing to invoke Xbox Live to log you in.

Hmm, I don't believe I did anything like that. It's giving me the option to log into Xbox Live, but it doesn't enter the game after that. Just loops back to the title screen over and over.

@Cardia360 Hmm.. I'd suggest having a peek at Reddit. They are collecting cases like this so-to-speak.

Now I'm having an issue where the game won't even open. It's like it's not installed anymore, but the disc space is still occupied.

Okey i have the same issue wasted 50$ worth of internet to download it .... and now i am stuck at Press Enter ! Re-installed the Xbox app and nothing happens !

Having the same problem. Can't get it to work. I have the xbox stuff. Nothing seems to work

Just solved it, you need to have the xbox live thing logged in and open

@Chochotron3518 said in PSO2 Title Screen - Press Enter Key:

Just solved it, you need to have the xbox live thing logged in and open

Can you please tell us how you manage to doo that !

I also am having the same problem.

I am able to get past this screen when I use my Xbox controller to continue. However if I press a key on keyboard or my Mouse it crashes.

Seems like most of the time when I use controller to get past I can navigate menus with my controller, but keyboard and mouse get locked out or frozen won't respond... I can't type in a name for a character....

@VisedBow1708454 Xbox (Beta) app. It'll ask you to install the Xbox Identity Provider. Lazy solution in some cases, but it doesn't always work. Sometimes it will still keep throwing you back to the login screen despite it

i read on many posts to install Xbox Identity Provider but Microsoft store dont want evne download this APP.... Maybe we are gona wait 8 more years to play this game ! 🙂

For me personally i had tried a lot of things with the looping menu and downloading the xbox console companion app, and launching it from there worked for me.