Launcher downloads latest version it says and it does so ebery time says its restarting but does nothing anyone know how to solve this?

Error pso 2.PNG it does this every time i open the program i just wanna download and play but i cant even download anything at this point in time. some help would be appreciated 🙂

so changing region doest make it better Also tried turning off and unistalling antu virus Didnt work either Also tried a VPN didnt work so pls if anyone knows anything PLS HELP im losing my mind and patience over here 🙂

I have the same problem, I enabled windows update, restarted my PC, and the game automatically got deleted, so be careful. I havent found a way to fix this garbage. If anyone knows how, let us know!

Exact same problem here, did one of you find a way around that ?

I already went trough the hellish desinstall once today, if I have to do it again there is no way I'm reInstalling it again a third time ...

I haven't found a way yet, Sadly. Hopefully one of us finds one, I'll post the solution here if I find one.

sorry to say this is still the same way even after all these hours honestly might need to give up and wait at this point which makes me quite mad that i wasted all day trying to figure out wtf went wrong here xD

Hey, I found how to get past this error, worked for me anyways. I had initially installed the game on D:, but I decided to uninstall it and reinstall it on C:. This fixed it for me.

ive had it on every drive i have its on C : as we speak but it does not work for me installed in on c d e f and even on my external G harddrive so im happy that fixed it for u but for me that didnt do anything sadly but im happy u got it working 🙂

Glad that you managed to get it to work but I already had it on C : so that won't be a solution for me.

But honestly I'm a bit tired of this mess and I think I will drop it for now and maybe come back in a few weeks / months if I hear that everything's patched up.

Good luck to every one still triyng to get it to work ! 😊

So, is there a way to solve this error ?

@carrecuir If you're on Steam, follow this guide and it will help you, i Just did it and it worked for me.

@ForemostCrab7 I did it for MS and after several attempts and maybe not correct repeats it started updating. at some pint it become japanese, but repeats fixed that. hope game won't fully redownload itself (60 or so gb got freed for me) and will launch well Thx a lot

Hi. I would like to tell my case ... and I managed to solve this error ... since it is due to a permission problem ... after much trying I was able to. but there is a tool that does it ... almost automatically, I used it previously with the windows store version and now with the steam version and it worked perfect for me ... its name is "PSO2 Tweak"