Game won't start after GameGuard

@Kid-Sizzle said in Game won't start after GameGuard:

I finally got it to work! So for those who are experiencing the problem where there are no error codes but the game does not actually launch after pressing the "play" button, it is because either the launcher or the Microsoft Store does not actually install ALL of the necessary files to run the game. I also have proof that the game works on partitions that are not your main partition (C: drive or partition with Windows OS) because I am running everything through my "D" drive (secondary drive). So it turns out there are about 23 files that were not downloaded through the regular process and that is why (for example pso2.dll or something I forget the name). I used the tweaker and ran a troubleshoot (the new one) and it installed 23 files for me and you have to be patient even after pressing "start" because it takes a few minutes for the executable to actually pop back up with the game.


By the way Ship 2 is always full...

that's cause ship 2 is busted right now

@DarkShadowRage Yea I know it is full of Xbox and PC players but sheesh, if the servers are full already then we really need 4-6 anyways.

@Kid-Sizzle said in Game won't start after GameGuard:

@DarkShadowRage Yea I know it is full of Xbox and PC players but sheesh, if the servers are full already then we really need 4-6 anyways.

it's not that it's full of players, it's literally broken, it's not actually full it's down.

@DarkShadowRage I'm on Ship 2 right now lol


So, I just found a working solution, and in typical Windows fashion, it involves a reboot!

  1. Reboot your PC. Trust me on this; if you've tried running PSO2 recently, there's some part of it that's still running in the background and it will mess up the following steps.

  2. Open Settings > App & features , and scroll down to "Phantasy Star Online 2". Click on it; that'll open additional options. Click "Advanced Options". PSO2_Reset1.png

  3. There is a section called "Reset"; click the "Repair" button. This will take a few minutes, but once as the checkmark appears, you should be good. PSO2_Reset2.png

  4. Try launching PSO2 again. It'll likely say that there's a new version of the launcher; just click "Back" button. The update will happen automatically after the mini-splash is displayed. It looks like it's downloading something, but not quite as large as the initial download (my guess, the Repair probably wiped out a few registry files, and since PSO2 doesn't know what's there and what isn't, tries copying the minimum it can).

Was finally able to get the game to work by closing Sonic Suite 2.

@Fezix93 This was it! This was the only thing that made it work for my partner! Thank you! We can play now!

Did not even have to reinstall (again) or change permissions, just closed Nahimic 2 and it started working.

@Fezix93 i have an alienware pc an they have third party audio software, after i exited and relaunche the game it worked.

I am having problem with game crashing at the logo part, no errors at all, just one with gameguard and i have no idea what to do. Been trying to play since launch. Still nothing.

turning off nahimic 2 fixed it for me also

@ShodBread192877 if your getting a gameguard error, then the pso2 tweaker might help

Glad I could help 😃 Sure wish someone told me GameGuard doesn't like audio programs before I spent hours trying to fix it

@Kid-Sizzle Thank you so much it worked

@Fezix93 Nope still crashes, so close to playing if it wasnt for gameguard.

i have RLY tryed everytrhing and the game still wont open after gameguard!.....

EDIT: after i closed my steelseries program (for audio/mic) the game FINNALY starts!!!!!

EDIT 2 : Game gone after restart again.... its hopeless

done also with tweaker but nope...