Game won't start after GameGuard

This is so bizarre... After my last post, I did the privileges on the file again, spent the whole day playing, afraid of closing the game and not be able to play again. Finished just now, and wanted to see if the game will start again, and now I get the Japanese launcher, and not working again

@Ragnador-GER said in Game won't start after GameGuard:

just check is wsappx is doing something in the background. on a ssd it takes sometimes around 4 minutes to complete the uninstall. many people start the install process while they uninstalling and this is creating issues. lile the pso2_bin slowly getting smaller then getting bigger again after reaching 0mb. ... while you try to start the game (looks like nothing is happening) - you only see a white bar under pso2 in the start menu. And if you dont wait for the uninstall process to be finished the backup folder creates a new folder and the old one wont be deleted ...

I was getting that white bar before I tried uninstalling...

@SixthBulb630463 So here's a thing I found out: DO NOT exit the game by hitting 'x' on the window. Only log out by using the logout button from the button bar in the game. Using "x" to close the window causes the client to corrupt and break. I have found that by using the game's "Log Out" button things work fine and I've had no issues. I strongly advise running the game in Virtual Full Screen mode, as that's how I've been running it without issue.

(The game is still laggy AF in the lobby areas but hey let's focus on getting people into game first, we can optimize later. 😰 )

Full Credit: Ginger Prime (YouTube)

@ColdinT don't bother, I tries 3 ssds and nothing

@Tigris1701 Hey! it's weird, I did log out of the game with the log out option. Tried to start the game again and launcher was in JP, my fix for this was going to pso2_bin folder again, while I had the JP launcher open, I gave myself full control of the edition.txt file, close the launcher, start it again and now I'm back in the game

It is horrendous the lag in the lobby and the shopping, what ship are you on @Tigris1701 ? Solutions i've seen for lag, that I'll try now are, setting on my NVIDIA control, the GPU as the preferred processor, and also select pso2 to run on the GPU. In game you can also disable the playback videos from the lobby on the settings. which I'll do now

Edit for FPS: definitely an improvement after doing that, considering I'm in ship 2 and it's showing full on every block, FPS is better than earlier when it was half empty.

@SixthBulb630463 So I have a monster gaming rig I built myself. An AMD Ryzen CPU, ASUS 470 chipset, NVIDIA Geforce RTX 2070 SUPER GPU, 3D vNAND NVME M.2 SSD where the game is installed. Motherboard has no on board GPU so everything defaults to the NVIDIA card because there's no where else for it to go. If you know of a good setting to flip in the NVIDIA control panel on that, I'll definitely go take a look.

One thing I've found that REALLY DOES HELP the lag and frame rate drops in the lobby areas is this: On the game's launcher go into Environmental Settings, Graphics tab, and DISABLE the option "Large monitor video playback settings" - Make sure it's set to "DON'T play videos on large monitor". This is NOT referring to playing in game cutscenes on your monitor. It's referring to playing the games cinematic intro on the large IN-GAME monitors in the lobby area. Which - when combined with a lot of your closest friends in the lobby area with you - makes frames drop like crazy, especially since there are usually two of these monitors in the main lobby area in game. Disabling this just means they show a black screen in game and it's such a small detail I don't mind it for the sake of how much it's helped improve the frame dropping. I'm gonna chalk up the vague wording on this option to a translation/localization issue.

Currently tweaking graphics settings to see if I can improve things further. 🤷

EDIT: Forgot to answer your other question. I'm on ship 1.

Well, using what @KerriganKitty said:

To uninstall the game, Open PowerShell as Admin and paste in this command

Get-AppxPackage -Name "100B7A24.oxyna" | Remove-AppxPackage -AllUsers

It does take a bit of time and it's not instant but this should help others having issues not uninstalling

and re-downloading it (first time) has me playing again. Don't know how long this'll stick, but I did copy a few important folders before playing to hopefully use as a backup...

Edit: Game crashed and went back to not loading past the GameGuard. Backups didn't help (didn't back up the actual launcher because eff messing around with taking control of the app from Windows).

I will add my 2 cents. Same issue. on second install with different antivirus. Not hopeful after reading this thread this will work. Since I used a 3rd party virus scanner windows won't let me use defender. Never found a solution to re enable Windows defender. I am not sure if it would be worth a windows 10 reinstall for this game. Very surprised this app is seen as malware or a virus. Isn't this a windows app for windows 10. I don't understand?

I am certain it will be fixed in time. Patience and just play Xbox one version if you have it.!

Haven't read the whole topic, but anyway. Tried re-downloading the game, tried copping parts of pso2jp client (gameguard and few .dll files)- didn't work. Realised that my game doesn't have the permissions to launch .exe files, so, edited file owner to my own and gave full control over the main folder- the game actually launched. Once in game screen, the screen was windowed, in totally different monitor (so, settings do not listen at all) and no key is working, can't Alt+ enter. Once quit the app, tried reloading it- it doesn't start, starts throwing japanese errors texts at me. Looked at the folder- it partially deleted itself. Currently updating the client once again.

pso2 tweaker now supports na, so I hopefully it'll fix the issues

Ok guys so check this out, I just got it to work right. I did 3 things. I deleted some "unknown user" permissions that was added to the pso2 bin directory (like 2 of them). I gave myself ownership of all of the files in that directory and added myself as a permission with full control. I then went into the pso2 bin and ran pso2.exe (not even as admin) and it opened the game. I doubt this will fix everyone's issue but I have been at this since yesterday and I know how it feels to grow up with this game and then experience this frustrating moment. Hopefully this was of a bit of assistance.

EDIT: You actually only get as far as the title screen at this point, I was also able to run it from the pso2 startup and launcher in that bin folder as well but it says "no user" when I reach the title screen.


Installed on my laptop, and couldn't get past the gameguard, nothing happens, tried everything mentioned here but no luck. On my PC I closed the launcher after download, turned off antivirus, gave myself premissions to the folders and now can't even get to see the launcher again, pressing play does nothing...

bump... please... its the second day and all my friends are getting well ahead of me. can we please get a dev to look into this?

@Kid-Sizzle You need to have the xbox companion app logged in with an account, that's how the game gets your ID

I'll try to summarize my experience to see if it can help someone, as I myself was in a similar situation of frustration and not understanding what was going on.

First I want to clarify why I had to re-install windows 10. That was me on the first day trying to delete the game, and all folders installed that day from the game (Most of the inside windowsapp folder) and then ended up deleting things I needed for some of my apps to run, and they would not work after re-installing them, hence my option was a fresh windows start. be very careful to what you delete inside the windowsapps.

If you don't wont to try anything until there's an official fix, follow most of the tips on link text after you delete everything on your PC, you might still have less memory in your drive. Right click on it, properties and do a disc clean-up. Also if you have CC cleaner or similar, run it on your registry and fix entries made by the game, since the files are gone it will delete the game entries.

This is what I did after my fresh install of windows 10

  • downloaded xbox companion app, went to MS store and added the game to a cart, then checkout (for 0$) and then launched the MS store app to install the game. The checkout and add to cart will help to get privileges on the game and I read solves some issues while downloading or trying to install it ( don't go to the store using "get" option)

  • First time around I installed the game on my SSD C :, which is my main drive for the OS, 500gb, 320gb empty space. everything fine, launched the game and same game guard loading and then nothing happened. I tried the fixes like using powershell as admin and add the lines of code for access, and also tried the privileges on the pso2 folder. Same result after game guard. Uninstall the game, with no problems this time, and no leftover files or space being taken on my drive.

  • Second time (or more like 5th, but 2nd since fresh windows10) I decided to install the game in my secondary drive, a HDD. It created the same folder, even some in C :, as I explained here link text. Did the powershell admin lines of code, and this time I tried it on both folders pso2_bin, which worked fine, and the oxyna folder directly under windowsapps, not the one under windowsapps>mutable>oxyna. That one didn't let me, powershell kept giving an error saying access was denied. Launcher finishes downloading, Game works!.

cd "D:\Program Files\ModifiableWindowsApps\pso2_bin"

first, then one line at the time

Get-Acl pso2launcher.exe | Set-Acl pso2.exe Get-Acl edition.txt | Set-Acl otp_notice_na.rtf

  • Closed the game by mistake, then I couldn't open it again. back to square one. I opened the launcher again, while it was open, not doing anything, I went ahead and changed the permission manually of the pso2_bin (since I could not do it on the oxyna folder) using the post AccelShift gave, getting ownership of the folder, making sure all the files inside inherit the privileges, then not adding a new permission, but editing 2 existing (second from the top between 2 that have full control, and the user under the one called RESTRICTION) clicked start game and it must have taken 1 or 2 minutes after splash was gone, and the game suddenly started. No errors from there onwards. After start menu, xbox companion window opened and selected my user.

  • Closed the game, and when trying to launch again, launcher was in JP... and this time wouldn't even get game guard to open. Check files again, while launcher open and done with the check, went to the pso2_bin, did exactly the same thing, and this time I went inside to the notice.txt (opened it and it says NA, but keeps launching in jap, meaning the launcher can't access the file) this time I added myself to the privileges of the notice.txt file. Closed the launcher, opened it again and back to NA, and game was working again.

I'm not saying this will work for everybody, but if you were in a similar place, and have the spare time and try it around, like I did, go ahead, I've seen a lot of people commenting "this doesn't work for me" or " this doesn't help me", well then that comment also doesn't help anyone... maybe your problem is other, go to reddit, there is a mega compilation there if issues and fixes, same in discord. Maybe you can find a solution, or an idea on how to fix it there.