Windows 10: Vivoxsdk.dll is missing

So, i tried re-starting my pc after that didn't work, now the game only says file not found when trying to run pso2.exe (MS store launch and launcher dont work anymore after restart). Gotta love how publisher manages to fuck up a game that only required translating....

I tried the xbox app thing but It don't fix for me too, any help? pls

@rafaell0player said in Windows 10: Vivoxsdk.dll is missing:

I tried the xbox app thing but It don't fix for me too, any help? pls

most of us stuck on this are out of options, I did send a ticket to support but with the launchday today they probably will take a couple of days to even get back to us on those tickets.

I gave a lot of permissions to access restricted folders and files not really knowing what I was doing and finally got to start game, then got that problem.

got the same error , trying to reinstalling now while i am logged into xbox live hope this will do the trick or else i am out of idea's tried everything. exept someone told that he installed it onto the main disk of the pc instead of a ssd but i dont have 70gb free on that 😕

@Ryukizaki8979 said in Windows 10: Vivoxsdk.dll is missing:

got the same error , trying to reinstalling now while i am logged into xbox live hope this will do the trick or else i am out of idea's tried everything. exept someone told that he installed it onto the main disk of the pc instead of a ssd but i dont have 70gb free on that 😕

Well I did try that as well, didn't work either.

Oh seems I found a fix for myself. seems the vivoxsdk.dll file in the installation folder had different security settings then the other files. So after the install was complete I took ownership of the pso_bin folder and made sure I also checked all underlaying files and folders. Then the same with the other settings.

Think I also saw this in another topic being mentioned, but when I first tried it, it was not working. I will try to find the link to that post and come back here.

I found a fix that worked for me:

  1. Open PowerShell
  2. Copy this and press enter: cd "C:\Program Files\ModifiableWindowsApps\pso2_bin"
  3. note: change "C" for "D" or the disk where you installed the game
  4. Copy this and press enter: Get-Acl pso2launcher.exe | Set-Acl pso2.exe
  5. Copy this and press enter: Get-Acl edition.txt | Set-Acl otp_notice_na.rtf

Hope it works for you guys.

OMG ! I'm on the game now ! It did work for the vivoxsdk.dll thing ! Take me all day to get that nightmare of a launcher to work ! thanks man !

@Morkalith said in Windows 10: Vivoxsdk.dll is missing:

I found a fix that worked for me:

  1. Open PowerShell
  2. Copy this and press enter: cd "C:\Program Files\ModifiableWindowsApps\pso2_bin"
  3. note: change "C" for "D" or the disk where you installed the game
  4. Copy this and press enter: Get-Acl pso2launcher.exe | Set-Acl pso2.exe
  5. Copy this and press enter: Get-Acl edition.txt | Set-Acl otp_notice_na.rtf

Hope it works for you guys.

@Morkalith said in Windows 10: Vivoxsdk.dll is missing:

Get-Acl edition.txt | Set-Acl otp_notice_na.rtf

this worked

@Morkalith

YOOOOOO !!! This WORKED FOR ME !!! holy FUCK !! Thanks DUDE ! iT solved my vivoxsdk.dll prob!

@Morkalith said in Windows 10: Vivoxsdk.dll is missing:

I found a fix that worked for me:

  1. Open PowerShell
  2. Copy this and press enter: cd "C:\Program Files\ModifiableWindowsApps\pso2_bin"
  3. note: change "C" for "D" or the disk where you installed the game
  4. Copy this and press enter: Get-Acl pso2launcher.exe | Set-Acl pso2.exe
  5. Copy this and press enter: Get-Acl edition.txt | Set-Acl otp_notice_na.rtf

Hope it works for you guys.

THANKS!

@Morkalith It tells me I don't have access to the files, UnauthorizedAccessException, I really fkn hate Windows and it's stupid access restrictions, got any workaround?

@Morkalith said in Windows 10: Vivoxsdk.dll is missing:

I found a fix that worked for me:

Open PowerShell Copy this and press enter: cd "C:\Program Files\ModifiableWindowsApps\pso2_bin" note: change "C" for "D" or the disk where you installed the game Copy this and press enter: Get-Acl pso2launcher.exe | Set-Acl pso2.exe Copy this and press enter: Get-Acl edition.txt | Set-Acl otp_notice_na.rtf

Hope it works for you guys.

Worked! Thanks!

@Metaldehyde Can you access the folder in the file explorer?