PC Download

UPDATE: Didn't work, I'll check files in the launcher till something pops up.

I'll keep uptading.

@TMIN-BadTed34 My wife was able to get to ship select, i am however still downloading the launcher hours later x.x

Ok here is what I read and talked with streamers/players, so I'll try to resume D':

Some technical issues you can meet :

  • 1 : Error while you start downloading the firsts 11Go from Microsoft Store > Solved : Change the region for US / Restart the computer once, then login in
  • 2 : Error because of your Windows10 version is too old > Solved : Here is how to proceed : https://www.youtube.com/watch?v=Q2UWKwpLy8A
  • 3 : First Error after downloading the 93k Files 2/2 in the launcher, It says "Cancel startup", update didn't worked > Solved : Just close the launcher and you'll see an other Error popup (4)
  • 4 : 2nd Error after checking files or relaunch > It says just wait ...

Personally, I had a very big issue in the last 2 hours, my game downloaded twice in a row and occupied almost 50% of my SSD ... (The duplicate was not found by automatic searches, it was in the windowsapps folder :((( )

When I try to log into the game in the bottom right it says there is no user; is there some way I need to log into xbox live via windows?

You have to login both, yes

Mines literally started working when i turn off my anti virus lol

I'm at " Cancelled startup of pso2update.exe. The file will not be updated"

Its ok, it's a normal Error message, you can't do anything more for this moment

QUICK UPDATE: I was able to go in-game. Think I fixed it, I could see even the ships.

@Aurack Cool, nice to see you bypassed all this stuff! Any tips?

@Grave-Knight said in PC Download:

@coldreactive said in PC Download:

Game does have GameGuard, in case anyone didn't notice it.

But why? Does GameGuard even stop anything?

GameGuard can sometimes trigger false positives with recording software such as fraps. I know XTrap can even BSOD your entire PC if it cannot end the processor task that it thinks is a cheat (IE: Fraps, which is a recording software.)

I don't use fraps anymore, I use OBS.

@DariusThorne I'll put a quick guide here for everyone but the tip is:

  • As soon as you're in the patcher and you get the error, don't close it. Click " Check file " till it pops up: " Your version is up to date ".

After that, click play and it'll begin to download again some files. Then you'll be able to go in.

@Aurack Aw shoot, I can't even reach the launcher. It's stuck on "pso2updater.exe won't execute"

@DariusThorne Re-install the entire game. When you open the patcher, meanwhile it's downloading the files, edit the properties of the folder pso2bin.

Give me your discord in DM and I'll help you here.

SEGA just updated on Twitter again that they are looking into the error code 1813 with the 'otp_notice_na.rtf' file