PC is forcing Intel HD Graphics instead of Discrete Nvidia GPU

Hello there!

I downloaded the Benchmark for PSO2 to see how well it would run in my old laptop, but it marks my Intel HD 3000 as my primary GPU when I have my Nvidia GPU set as the default one for the PC. And it shows, as I barely reach 50 FPS with standard quality settings.

Will the full game detect the Nvidia GPU as primary? Or will this issue persist? If so, how can I force the game to read my Nvidia GPU as the default one? I already tinkered with the settings in the Nvidia Control Panel so all programs should be handled by it.

You shouldn't have any issues with this playing the actual game.

That is normal. In a lot of cases, if you don't disable the integrated GPU when you have a dedicated HPU, it normally always defaults to integrated. You can change this by adding the executable to the dedicated GPU's control panel and setting it to use the dedicated GPU instead of the integrated one.

@Gordoesmito said in PC is forcing Intel HD Graphics instead of Discrete Nvidia GPU:

Hello there!

I downloaded the Benchmark for PSO2 to see how well it would run in my old laptop, but it marks my Intel HD 3000 as my primary GPU when I have my Nvidia GPU set as the default one for the PC. And it shows, as I barely reach 50 FPS with standard quality settings.

Will the full game detect the Nvidia GPU as primary? Or will this issue persist? If so, how can I force the game to read my Nvidia GPU as the default one? I already tinkered with the settings in the Nvidia Control Panel so all programs should be handled by it.

You can try change the settings on your Nvidia Control Painel the following setting in Manage 3D Settings section:

Preferred graphics processor: Auto -> Nvidia Geforce Whatever(insert your gpu model here)

It should work, but I won't give much hope to you since the game is running under UWP.

@Ragnawind said in PC is forcing Intel HD Graphics instead of Discrete Nvidia GPU:

In a lot of cases, if you don't disable the integrated GPU

In the case of Nvidia GPUs that hybridize with Intel (which is most pre-built nvidia systems), disabling the Intel GPU actually disables the NVIDIA GPU (despite the Intel GPU being disabled in Windows when you reboot. The Intel GPU is still running, and won't let you switch to the NVIDIA GPU, because Windows thinks you're using it.) I had this problem before for certain games and tried to disable the Intel GPU in my BIOS.

The only real fix according to NVIDIA is...

  1. Right-click the NVIDIA System tray Icon.
  2. Choose "NVIDIA Control Panel"
  3. Navigate to / Choose "Manage 3D Settings"
  4. On the "Global Settings" tab, make sure your NVIDIA GPU is selected. (IE: "High-performance NVIDIA processor.")

I'm still downloading the game but I have already seen some people running into the same issue. A solution I have seen is to change the Universal App Setting for PSO2 to use "High Performance" so it uses the Nvidia GPU, but I lo and behold my PC appears to ignore the fact that I have an Nvidia GPU as seen here.

Does anybody know how to change this?

Did you tried to do that in the Nvidia Control Painel, by adding the PSO.EXE into the custom list?

I'm having the same issue and after changing my Nvidia settings, the game won't even launch now. No error, absolutely nothing. All I get of any semblance of a program starting up is simply the fans kicking up for a moment.

The problem many of you are facing is the result of MS Store apps defaulting to the integrated GPU, this is something which you need to set not in your GPU's setting but the Windows 10 graphic settings, here is an illustrated guide I made which should help solve this problem:

1_new.jpg 2_new.jpg 3.jpg 4.jpg