Infinite loading screen

I can get into the game fine, but when I enter the gateway ship and jump into the portal, i get stuck in a infinite loading screen. Edit: Looks like it's only for specific areas. So far it's been tundra and ruins.

Hello there! Thank you for your report. Can you provide us with a little bit more info?

  • What ship are you on?

  • Does it happen on all blocks? If not, then please list at least one block it does occur on.

  • Does it occur on any difficulty?

  • Which console are you using? For example, Xbox One X or S.

If you still experience this issue, please submit all info listed above in a ticket on our support site, so we can assist you further. 😄

@GM-Rappie It was on ship 1, i dont remember which block it was on, but deleting and re-istalling the game fixed it for me.

I'm having the same issue except I'm not able to get into the game at all. I select my character on Ship 1 and it loads infinitely. I'm on PC and have already reinstalled the game with no effect.

I have just faced this issue, was entering area 3 of tundra when this happend. I have tried login into a different ship but till loading. I am able to use the chat while loading but not anything else, now rechecking the game file. Hopefully I don't have to reinstall again for the 6th time since launch.

I've had this happening as well, right after selecting a character to enter into the game it just gives me a loading screen with a Doctor Who kinda loading screen tunnel that just doesn't end. Have had the same effect on ship 1 and ship 2 and have waited up to 1 hour but no change. PC here as well, I've done the file check and already have completely reinstalled the game as well, but no change.

I've also had the same problem, got my character to level 60, now everytime I go into the game and select my character I get stuck in an infinite loading screen. If I click create another character the game black screens. I can use chat and it says i'm in the arks lobby during the loading screen but I can't do anything other than close the game...

I'm beginning to get infinite loading screens for urgent quests.

I'm also experience frequent disconnects in the lobby and shopping areas, either while idling, or when making menu selections in storage and shops. It is seriously degrading my PSO2 experience. I cannot appear to stay in some blocks on Ship 2 without being disconnected within 7 minutes of logging in.

Any solution? please

Hey all, I just solved this issue for myself. On Windows 10 I went: Start Menu>Settings>Update & Security>Windows Security>Virus & threat protection>Manage settings (under Virus & threat protection settings)>Turn Real-time protection off. Real-time protection will turn itself back on eventually, so my solution is to always turn it off BEFORE launching PSO2. This solution has worked for me with a lot of issues in games. It has something to do with the read and write permissions your user account has while Rtp is on (which is to say, it restricts those permissions). Hope this helps.

I'm having the same issue, but I can't enter the game at all. After picking a character it's stuck on loading screen.

@Chief-Swelling-Brain It's too dangerous to turn off that setting, isn't there a method to white-list the false negative?

@Chief-Swelling-Brain Thankyou I have found the solution from you. If you dont wanna turn it off everytime you launch pso2 you can just manage the settings in ransomeware protectionin the virus and threat protection. Go allow pso2 through Controlled folder access. Hope this helps.