Getting stuck In loading screen

Hopefully someone can help me with this issue. I've been having this issue ever since the update for the braver class was added into the game for NGS. I have been unable to load into certain areas which include 2 ryuker devices which are close to the town ruins (west aelios) I just get stuck infinite loading screen and the other ryuker device in Laboratory ruins as well. As well as trying to access the story quest "The trio goes to battle" an newer and existing characters It just gets stuck in infinite loading screen as well as the recently added Aina's side quest. Is anyone having any issue with this? I contacted support and the only thing they said was to delete the contents of the temp folder for the game, but that hasn't fixed my issue and Im currently still having it. It's been a bit frustrating because of it.

I'm currently playing the game on PC through Steam.

lets run a check list

  1. is PSO2/NGS on exception list for any security programs?
  2. have you tried verifying file integrity to see if any files are missing/corrupt
  3. power cycle modem and/or router
  4. lower graphic settings to see if that helps
  5. if all above methods failed tried to reinstall