Constant crash in PSO2 NGS - SEGA please fix this!

SEGA please try to fix your issue. I have these constant crash issues for the game, and it HAS NEVER HAPPENED BEFORE THE PSO2 graphical update, at least not as far as I can remember. Now every so often it will crash. For me it seems to be quite random, although it's more when I'm active. I haven't tried idling but I think idle does not crash my game. It's only when I move that there is a chance to crash. Something keeps getting corrupt.

No, it's not a GG error, I get the 'pso2.exe has stopped responding'..... which again, does NOT clarify what exactly happened. Other times it will just freeze, no crash, just hard lock, and have to close with Task Manager.

WHAT IS HAPPENING?

I am bumping this because I would like to know if anyone are experiencing a similar crash as me.

Huh. This is an update on the situation...

I do not know what exactly happened to cause this, but simply put, I am no longer having freezes/crashes issues. I did have a crash yesterday, but that was it. Just one single. It works flawlessly all of a sudden. I think restarting my laptop mustve done the trick. Though my laptop was shut down improperly....

Weird...

I made several posts here regarding the same exact issue: https://forum.pso2.com/topic/13302/game-freezing-since-this-maint/4

Already tried the following:

  • Uninstalled and fresh reinstall of PSO2
  • Restarted PC
  • Tried launching with Tweaker and without Tweaker. No change.
  • Launched in Window Mode.

Game client will run beautifully from anywhere between 5 min to 20 min max. Suddenly then freezes.

alt text

I have the same issue with the game locking up and crashing randomly, but VERY often, I can't play for more than 10 minutes without a crash most of the time.

Only game I have that's doing this and I have a good pc so not sure what's going on here but it's driving me nuts and away from the game, can't even do all my dailies in 1 login because of these crashes, takes me 2 or 3 every day and that's all I feel like doing because of it.

Welp. I see this wasn't fixed during maintenance. Still having the same exact issue.

alt text

I only got one with the preview the 5 pose emote then a hair crash that has been reported and now on nex aleio on the island in west aelio.

Still crashing, and have a friend that is running a RTX3080 that also has this issue.

Lost another Gigantix because of this stupid freeze. SEGA hasn't responded to my tickets in almost a week. Getting pretty close to done with this game.

This needs attention and needs to be addressed or people will be quitting over this. I know I am not the only one and many are affected.

alt text

Hey there, friends! I was in the same boat as you until 2 days ago, my gaming experience often ended with annoying "pso2.exe stopped responding" hangups, I also had other issues (which I covered in this topic). Deleting content of SEGA folder from My Documents solved all issues for me, no problems with game at all after commencing that action, not a single hangup since then. Maybe it'll help you somehow, I think it's worth trying if anything else failed till now (just make a backup copy for safety purpose before deleting and don't worry, catalogue structure will be recreated after you launch the game, it'll create new files).

It seems that some files in that catalogue were corrupted after update patch on June 23rd when SEGA implemented Gigantix bosses. Hope that dev team finds appropriate fix if this issue occurs again in the future.

Kind regards!

^^ Tried the above in hopes this would fix the issue but no dice. Thanks for the help anyway.

Back from a small break

alt text

The fact that SEGA hasn't even acknowledge this is mind blowing.

@Chrispy0530 You may check temperatures on your CPU and GPU (maybe they heat too much and constant stress causes hangup issues, maybe it's time to attach thermal paste again), try with Command Prompt (executed with Administrator rights) and sfc/scannow command, it repaired some files for me as Microsoft Store modified some integrity packages on its own during disconnects.

I remember that I tried other things as well: adjusted in-game graphics options (especially Anisotropic Filtering to 8x, 16x one caused some sort of instability) and graphic driver's performance in nVidia Control Panel (Power management mode set to "Prefer maximum performance", rendering set to my GTX 950 in order to prevent integrated Intel HD4600 card from doing anything in the process), changed power plan in Windows 10's Power Options to High Performance (Control Panel > Hardware and Sound > Power Options), adjusted Graphics performance preference for Win 10 desktop apps and set "High Performance" for my all PSO2 installations as I operate on 3 platforms for safety purposes (Settings > System > Display > Graphics settings), as well as added an exception for pso2_bin folder to Windows Defender and antivirus software. I thought that maybe 471.11 nVidia driver caused issues but it's good so far.

Hope that SEGA gets this issue acknowledged fast and implements any fix because they'll lose more players due to this bug, it's really annoying and game-breaking experience leaves a bad taste. It's not someone's hardware issue if more people experience this state on any platform (I had crashes on every single one, Steam, MS Store and Epic Games Store), not a single hangup since July 11th.

Kind regards!

Thanks for the suggestions. The CPU and GPU average temps on PSO2 generally averages around 54C (CPU) and 65C (GPU).

PSO2 NGS was working perfectly for the first week when it was released with no crashing issues at all. It was when an update after maintenance had dropped where these issues began.

Just got home ready to play. But sadly another maintenance has gone by and still no fix.

alt text

Done with you SEGA. After two ignored tickets, reloading Windows entirely and still no fix. Not worth the headache. Will not by renewing premium/playing anymore.