Lock-on not sticking to the mob, is that normal ?

I've tried to check if there is an option for it but I couldn't find it. I hate when I lock-on on mob ...then another gets in front of it or I move a bit and the lock-on moves to another mob or loses it totally. And that's a PITA when you charge a Ice attack only to get the mob switched to another that is weak to fire ...making it pointless. It makes it quite harder to attack the proper weakness when it keeps switching on his own. No, I didn't move it or click to remove it. It happens even if I stand still, if a mob goes in front of the locked one or it moves even a bit it gets switched to that or removes it. Another thing is the way it targets one if you do actually remove it and the re-set it. I've set it to lock on the one's I'm watching, but it always gets the farthest one's, like a lot far and most of the times on the sides...instead of the 10 or so I have in front me a few meters from me.

@ShinoKoba Emergency maintenance is basically already started, so I can't go and reproduce this behaviour to test it right now.

However, I could have a better idea about what might be going wrong there if I first knew your input method. Are you using a controller, or are you using keyboard and mouse?

Gamepad as method to play. You use the d-pad to switch target when it's locked on and LB to lock-on/release it. But I didn't do it. I tried standing still ...and if the target moves a bit it loses it or get switched by himself. At first I thought, maybe I'm too far ...but keeps doing no matter how far or close I'm (different thing from what I posted on another thread, I tested and proved it's because of the distance ...tho even that shouldn't happen unless you are under his feet).

@ShinoKoba Well, here are the things I'd say you need to check in NGS configuration screen when the maintenance is over:

  • Make sure that locking on is set to 'toggle', and not 'hold'
  • Make sure that controller is set to the primary input method
  • Make sure that camera settings are set to give priority to where the camera is facing, not to where the character is facing
  • Make sure that the NGS mouse settings screen are configured to prevent the game from polling the mouse's position to determine a lock (I can't remember the exact wording of this option)

If all those things are set like that, it should behave like how we'd normally expect it to behave, where the lock will hold no matter where the enemy goes, until they get out of range. But if all of that is set up that way and the problem persists, then you may have found a serious bug which will need to be reported the developers.

Maintenance ends in 5 hours, so I will also check this out as soon as we can go back in.

Thanks for your answer, Everything aside the Mouse polling , that I'm sure about as I didn't touch anything there, is already set that way. The thing about the Camera was set initially like you suggest ..only as a test I tried to use the other method. Same goes for the hold ...I tried that as well (Hold instead) but it made using skills/tech too hard and anyway didn't change anything on the target lock-on behavior so I set it back to default.

I think some of it is likely related to the lag. the best way to navigate the lag right now is that something is still alive as long as you can target it (and in turn, hit it) and that it will still be "alive" once it's hp has been depleted, but it cannot be targeted or actually hit with attacks. As I posted in the other thread. When this happens, since i'm usually always moving to the side, I tend to turn and launch my tech into the nothingness to one of my sides(or another mob that may be that direction). While I cannot say this is what is happening for certain, I am assuming this could be one of the probable causes.

@FoolsArcana said in Lock-on not sticking to the mob, is that normal ?:

I think some of it is likely related to the lag. the best way to navigate the lag right now is that something is still alive as long as you can target it (and in turn, hit it) and that it will still be "alive" once it's hp has been depleted

I understand what you mean by that. But that is not the case, as it happens even with a newly targeted lock-on. Like, it moved from the original one and then moves again when I move or he does so it's HP is basically untouched. Sometimes I didn't even hit it before it switched (and yes It does even when I'm alone so no one else attacked it/killed it). It's not a question of range either since you need to be close enough to use "the rush" or it will hit nothing and waste it.

@ShinoKoba Ah. I have not experienced this then.

After a bit of playing, not sure if it's related to the reason of the Emergency maintenance ...but for now seems the lock-on it's keeping on target. Only tried with a group of at most 4 ...but still never moved till the target died ..so it's good ^^ .

Good to hear that everything is working as normal again. It must have been lag-related like FoolsArcana had said.

Yeah ...I can definitely say it was fixed. Even when they used teleporting-like moves the lock-on still stuck. But we still have some lag spikes. I was in a party right now in the Forest just killing random mobs, and even that Dragon (I guess he is like the Dog-like of the Mountain as the burst climax ) at the moment I write, and everyone had the same. Even in alliance they all some lag spikes. We even joked about having another 5 hours EM 😂 🤕