My character never loads past introduction:Xbox

Hello, I've tried for 2 days to load into NGS with my main character and it never gets past the intro screen and remains black. I created a new character and played for 25 minutes but the NPC Garoa asked if I wanted to rest now I'm endlessly running on beach with no menus? What should I do?

@Enslaved-Player Sounds like either a major bug, almost nobody I know has run into, or you had a bad/corrupted installation. Which model or Xbox is it by the way?

I had the exact same thing happen to me at launch day on steam. I was in the tutorial and after skipping a cutscene 20mins in, I got a blackscreen. After that, everytime I got into the game, the first cutscene would always result in an infinite blackscreen. I had to reinstall the game (thank god my connection only needs 10mins for that), but after that, everything worked again.

@Yui2387 So it is a bug, and it's hit and miss.. Hopefully a GM sees this, and places it in the bug section so it doesnt get buried in general.