Any reports of memory leak in PSO2:NGS? [Solved, not a memory leak]

I am trying to troubleshoot an issue that I am having with PSO2:NGS.

My computer is capable of running the game (see benchmark below), and sometimes I am able to keep the client open for 8 hours ~. Occasionally my computer will completely shut off while the game is running; somehow the game seems to cause a power surge in my PC. My main issue is that I use my computer a lot, and I've never encountered this before, even when using the machine for long 3D renders in the past.

At first I thought it was my GPU overheating, but it's not the case after seeing the temp at around 65C right before shutdown.

Has anyone else had this issue?

Benchmark: pso20210527_144124_001.jpg

EDIT: I have now resolved this issue, the problem was related to a default feature in my motherboard BIOS settings (ASUS), which triggers PCB sensor based anti-surge when the system gets too hot.

Can read about it here if you have a similar problem: https://www.overclock.net/threads/asus-anti-surge-is-a-broken-mess.1552794/

I have also had this odd shutdown issue while playing NGS. However, it has only happened once so far. But yes, that one time my computer literally shut completely off... which is very odd.. never had that issue before on this computer.

hmm never had issue nad played game for half a day straight.

and im runnign a i3-4130 with 1060 6gb (and 10gb ram..dont ask why)

@Maymay1611 Do you remember if there was an error message during boot up after turning it on? Maybe something that prompted you to change BIOS settings?

It's happened to me, first when checking out the new graphics engine when it released on JP PSO2, a couple times in CBT, and now twice during the actual game. Every time with the same power surge error, while running PSO2 with the new engine.

@favouriteSoup Based purely on your description, it sounds like you're experiencing one of two things:

  • Power supply insufficient to sustain high GPU and CPU utilisation at the same time over extended periods
  • Power supply has aged and is now close to failure?

@Rei-Murasame Yeah it could be the second one, I am thinking that too. But like I mentioned, it's never happened to me outside of having the NGS client open. It's also varied in how the shutdown occurs, for example, one time it happened around 10 mins after logging on, another time several hours after.

My thought is that somewhere in the program there is a write that runs more than it should, but if no one else has the same issue I should probably get a new PSU.

@favouriteSoup I have the same issue. Thanks for the solution. The game runs fine then my computer shuts off at random intervals. Sometimes a few minutes, sometimes hours later (while playing NGS). I do not receive a bios message prompting me to change settings at all after it shuts down (like something you would see on a failed overclock). I do have to unplug the power from my computer and discharge before it lets me boot again. Any other game I play on my computer runs just fine (even during extended sessions) so I don't think it's a power supply issue. For reference, I have an Asus Crosshair VIII Hero, 5900x and an RTX3090. I don't have the anti-surge setting in the bios but I turned off monitoring for 3.3v, 5v, and12v. I was able to play for a couple hours today without any issue. Will try playing again later to see if it happens again.

@Gammie Yeah, I can only really say this solution is helpful for Asus motherboards with the anti-surge PCB built in. If it is the same problem you would get a message saying "Asus anti-surge was triggered to protect the system from an unstable power supply!". Otherwise, I believe there are some reports here and there of the game not running as expected on high end gear like yours. Not sure if it will be better supported with later patches.

One other thing I was about to do, was set up performance monitor so that I could log the usage of RAM as the computer crashed, but as I found a solution I never tried it. It is going a bit far to be honest.

I encounter this same issue on my Dell G5 SE laptop. At first I was able to play for hours no problem. Then I started getting black screens while the BGM would continue to play, so I thought it was overheating, but even with an elevated cooling pad I'm still encountering the blackouts at random moments even with decreased graphical settings.

Apparently the issue is bloom settings from wat I heard, ppl are trying to pinpoint the root cause of the issues in this game daily. ;3

@favouriteSoup what was your solution? having the same issue's